Apache does not work after EndOS update

Good day,
Apache stopped working, after system update : Atltntis. Error:
/opt/lampp/bin/httpd: error while loading shared libraries:
libcrypt.so.1: cannot open shared object file: No such file or directory.

  1. ‘sudo pacman -S libssl1.0.0’.

  2. ‘ln -s libcrypt.so.2 libcrypt.so.1’ Didn’t help.

  3. ‘yay -S libxcrypt-compat’ : gives errors here.
    The error occurred after an update on the laptop.
    A couple of days later I did an update on a PC and got the same ,
    i.e. Apache does not work and the error is the same.
    So it’s very likely that it’s about system update.

What else to do, I do not know, please help.

Where did you get apache from?

1 Like

If you use Apache from the repository then it’s built against system libraries.

If you want to use a third-party installer then putting it in a VM or container will be the better approach. You’ll probably find there are VM appliances and containers already available that make setup easy (not that Apache is massively difficult to set up as it is).

1 Like

I use XAMPP.
Installed at terminal.

sudo xampp-linux-x64-8.1.2-0-installer.run

I have done this 10 times over the years. It was no problem.

Right, but Arch libraries change all that time and the old binaries are no longer compatible with the system libraries.

When you use manual installs like that, you run the risk that updates to Arch will break them. Which is exactly what happened here.

You have just been lucky in the past.



  1. I have XAMPP uninstall.
  2. Run Pamac.
  3. In AUR found XAMPP.
  4. Clic - will install.
  5. Crash of Pamac.

Three times tried - the same result. :cold_sweat:

That is just an AUR package of the thing you had before. It just runs the xammp installer. That isn’t a copy of Apache built against the repos.

Sounds like a bug. You can always use a yay or another AUR helper.

That being said, if you really must use “XAMPP” instead of proper installs of it’s components or installing it in a container, you can try installing the package libxcrypt-compat

1 Like

First was a mistake, now made (photo).

unfortunately does not go again…

What doesn’t go?

1 Like

Apache, but THANK YOU!!!
After new start (operating system)
XAMPP runs :star_struck:
Thanks once again

1 Like

Something is wrong with your system:


Yay is telling you not to run it using sudo, but you do it anyway. The fact it doesn’t work correctly as your normal user should highlight there’s a problem.

1 Like

Yes, that is right.
But now all - Notebook - is Ok.
PC: here i have done without sudo.
Also no problem…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.