Anything (new) to know before I install EndeavourOS?

Greetings lovely community,

So, I’ve been mostly on Fedora 37/38 the last year, hence my absence for all the latest happenings and updates in the Arch World. But it’s all Linux in the end! Well, it’s that time again where a new change is in order for this computer, so I burned the latest EndeavourOS .iso version 2023.05.28.

The .iso itself is only less than ~2 months old, so I’m not worried about using it to install EndeavourOS, however since I have been mostly out of the loop since the grub fiasco of last year, I was wondering if there is anything I should be made aware of from this year in the Arch world? Like any specific changes that EndeavourOS dev team did that might be worth knowing?

I’m currently backing up a few things, but I expect things will go smoothly for an install. If I encounter any issues, I’ll be sure to create a new thread. Can’t say it just yet until the install is done, but I think it’ll be good to be back in the Arch world. Fedora was great, it just worked, but I just want to tweak and tinker again and I know EndeavourOS and it’s community is the perfect place to start that journey.

If you know…you know! :wave: :clown_face: :broccoli: :frog: :robot: :turkey:


Were you still here for the switch to dracut and the inclusion of systemd-boot? I would say those two would be the most material changes.

1 Like

I was around when you put up a giant thread to switch to dracut/systemd-boot and I was able to convert my install at that time successfully to systemd-boot and dracut. But it was a lengthy process and I’d have to search for that bookmarked post again, unless the EndeavourOS installer now does all that via a toggle or switch I hope?

Edit: I am going back also, and read any Wiki/blog post I might have missed.

Yes, systemd-boot/grub is a choice in the installer.

All installs get dracut by default now.

1 Like

I remember I had 3 kernels back at that time, linux, lts, and zen. I don’t really even need the zen kernel anymore to be completely honest, but I remember having issues with having 3 kernels and my EFI or something being too small on dracut to fit all of them. Maybe it wasn’t the EFI, my memory is not the best, but I remember having that difficulty.

Is dracut improved since last year in that regard or others? Also, thanks for the quick replies too! Also, I remember back then, we had to use one or two packages from the AUR to get dracut and everything up and running. Is that still the same or does EndeavourOS have them in their own repos now maybe or still in the AUR? kernel-install-mkinitcpio or kernel-install-dracut or something similar I think?

It was probably your EFI partition size. For new installs we create a 1GB EFI partition so that should be less of an issue.

kernel-install-for-dracut is now in the EOS repo. kernel-install-mkinitcpio is still in the AUR since we ship with dracut now.

1 Like

Right that sounds good then, looks like those things check out fine for me. My plan is to stick with sane defaults (no, not you grub) since I don’t have anything specific I need configured. I like and appreciate the defaults that EndeavourOS devs have set so I’ll be sticking with those I think. Still backing up a little bit, but looks like I’ll be giving EndeavourOS a go again within this hour. Fingers crossed my Nvidia doesn’t give me multiple black screens! :enos: :+1:

1 Like

Welcome back @Scotty_Trees

Myself i am still running mainly KDE Plasma still on both desktops with Wayland now. Never thought i would but it’s come along and I’m extremely happy with how it’s working. I have it on both my Nvidia desktop and amdgpu desktop. I’m also still using grub with btrfs, btrfs-assistant, snapper-support and btrfsmaintenance. Not one issue in a long time. I also stick to mostly the defaults.

Sorry I can’t react with broccoli to your post since it looks like emojis for that are a set number now, but I’ll interchange the dino or the broccoli as I see fit to keep you on your toes! I figured as much you’d still be doing the same old same old! If I run into any Plasma problems, you’ll definitely be the first to know! * goes off and installs Gnome * :sweat_smile:

What hardware are you installing on now? The same as before? I forgot what it is? Hybrid laptop?

1 Like

Yup same laptop as before, Acer Aspire E5-575G with 16GB RAM, Nvidia MX150 + Intel Integrated Graphics. Just finished my last backup so now there is nothing left to do but… :computer: :technologist:

Are you still going with Gnome?

Edit: For some reason i thought you had a Lenovo? Must be someone else’s hardware I’m thinking about. :thinking:

1 Like

You definitely have me confused with someone else, but you’re always confused (kidding!) anyways, so it’s really okay :wink:

I’m never confused. :lying_face:

Edit: Okay…haven’t you got that installed yet? :rofl:


Grub is practically the defacto standard. The overwhelming majority of all Linux ships with grub. It’s one of the most sane defaults you can have. You more than likely area still using it on your Fedora install.

Either way, welcome back. I’m still on F38 myself, and loving it. At least on my gaming PC. Thinkpad gets everything lol.

Not me. All my Fedora installs use systemd-boot. It is one of the easiest distros to switch over since it already uses kernel-install.

It defaults to grub though I thought. Mine did at least. . . I don’t really care one way or the other. Both work very well.

It does use grub by default. However, it uses it in a BLS compliant way using kernel-install.

Since kernel-install is part of systemd-boot, that creates an interesting situation. If you simply remove all the grub-related packages, it starts using systemd-boot on it’s own. I don’t know if that is deliberate or a happy accident but it is convenient.

Huh, so literally just like, remove grub. . . and it fails to systemd-boot? LOL I may try it on my Thinkpad just because I find that interesting.

1 Like

Yeah, I haven’t reinstalled in a few versions so I can’t guaranteed it works out of the box on F38 so you might not want to test it on a real install that you use :wink: