Anyone get the Google Play store to install on Anbox?

I’m trying to install some apps via the Google play store with Anbox, has anyone gotten it to install? I’m kinda stumped the workarounds online show you needed to run some bash script from someone’s github but that no longer exists. Any ideas?

Never used Anbox here but just a thought: can you install F-Droid? If you can then you could install Aurora Store which can install apps from Play Store. Then If you need to sign in to Play Store to use your paid apps this might not be an ideal approach since I’ve read here and there that if you use your Google account to sign in to Aurora Google might lock you out from your account. I have never tried to find out :wink:

Edit- you could also download Aurora’s APK directly from:

Anbox has never worked without a lot of hassle for me. Their images are quite old and if I remember correctly, do not offer arm support, so even if you manage to have a working playstore odds are a significant number of applications would not run.

There are, in my opinion, better alternatives worth considering depending on your needs.

  • Waydroid is a more up-to-date version of Anbox for Wayland. Does not support Nvidia cards, so it would need to run on iGPU or software rendering if you have an Nvidia card. Small config required for this, it is available on their Wiki I think, but I cannot find it at the moment.
  • Genymotion is an Android emulator for Linux with an easy click-to-install open gapps (google play services). It does however have a watermark at the bottom for non-paid users. There is also a flashable arm translation available so you can run apps requiring it as well, simply drag and drop over the emulator window.
  • Gnome-Boxes (or another VM) with BlissOS. No watermarks, comes with play services. I could never make the 14 image work, but the 11 one runs perfectly fine.

My personal recommendation would be this: If you don’t have an Nvidia card, and you’re running Wayland, go with Waydroid. Otherwise have a look at BlissOS.

1 Like

I have an Nvidia card so Waydroid seems to be out of the running. Genymotion seems to be paid software but I would like to stick to FOSS if I can help it.

A VM like Qemu/KVM and vert manager seems to work with BlissOS or something like Android x86.

You can run Genymotion with a free account, but it is indeed closed source. A VM with BlissOS is likely your best option. I have an Nvidia card and run Waydroid on software rendering. The performance is fine for standard applications, but it takes a hit when tasked with something more intense like games. Give Bliss a shout, hopefully it’ll suffice. Like I said above, I had trouble installing version 14, whereas 11 was fine. Your results may differ though.

1 Like

I installed BlissOS version 11, games seem to work great on it except there is some annoying features of BlissOS, when you start it you are bombarded with 3 different desktop managers on android. For some reason you can’t even uninstall them, they are just there to annoy me to death. Its almost impossible to turn them off too, Ugh.

Quite confident there’s a popup when you start it asking you which launcher you want; desktop or android. If you have selected one permanently I believe you can still change it somewhere in the application settings, if not, then by a reset of app defaults (again, in settings). Just like an android phone.

Never used Anbox here but just a thought: can you install F-Droid? If you can then you could install Aurora Store which can install apps from Play Store.

I would say to go for this. I used aurora with a google account for a few months before I deleted my google account and I never had any issues.

1 Like