Annoying KDE wallet popup everytime I launch Brave

I was using XFCE , recenlty I switched to bspwm WM and everytime I run Brave browser I get a message about this. How can I fix it?


A message about what? What’s the message? Screenshot?

Added to OP. I want to make a script so that I launch all the applications I want in desired location in bspwm. This is one of the problems I am facing for that end.

There is not much documentation I can find on the subject. The best I could find was this on Archwiki:

KDE Wallet - ArchWiki

To unlock KWallet protected by the login password, it is necessary to add

 exec --no-startup-id /usr/lib/pam_kwallet_init

to the configuration file of the window manager in addition to configuring PAM.

Try just clicking OK without entering a password.

If it doesn’t allow you to move forward, enter a password, then select “Blowfish”. Then, when it asks for a password again, just click OK without entering a password.

It shouldn’t bother you anymore after this.

1 Like

If I press OK, it is going to ask for password endlessly and don’t progress. I have to click “Cancel” 3 times in row to open Brave for me. And it is going to ask for it next time after I close all instances of Brave. I don’t know how to select “Blowfish”. I don’t ask me anything other than password.

Log into KDE Plasma and try it again, please.

If you still get the same popup with no “Blowfish” option, delete the folder below and try again.


The thing is that most confusing for me is I had never used KDE. I was using XFCE before switching to bspwm. There are some suff in the directory you mentioned. Is this going to cause lose my passwords in my browser memory? I don’t have issue with that as I don’t want them to be saved there in the first place.

No. It won’t.

So just delete that directory? is it safe?

Yes. But since you feel it is not, just rename the directory to kwalletd-bkp.

It will immediately get recreated once you launch Brave again.

Sure I make a backup. lets see what happens.

By the way, if you have KDE installed but you’re not using it, that can cause problems with your other DEs/WMs. In addition to this, it causes more updates, longer updates, and it takes up space.

1 Like

I think it is only chrome / brave that uses it under the hood. Maybe it asked me about this first time and I messed it up. After deleting the directory , I chose Blowfish and setup a password for it. Still not sure what is kept in there and should I keep that password or not. But it is working now. Thanks for the help.

I actually said that you should not enter a password after selecting Blowfish. It is likely to ask you again next time you log in to one of your DEs/WMs.

Please redo the process but do not enter a password after you select Blowfish.

After doing so, then you can close this thread by marking one of the answers as the solution.


Sorry, I forgot that. I deleted ~/.local/share/kwalletd directory again but it is not asking for a password or anything anymore even after deleting it.

Maybe need to log out and back in. So, delete it one last time, log out, log back in, launch Brave.

I use pass (Password Store) and its firefox addon PassFF… Kwallet used to unlock my gpg pass at the startup but now PassFF asks for gpg password every time I launch firefox as well… KDE6 certainly changed a few things for sure.

I totally agree with ddmm on this. I had the same problem years ago and solved it the same way as he suggests.

1 Like

This is a blast from the past lol

I remember many years ago it was commonly enabled in distros. I just remember it was pretty easy to disable or delete. I can’t believe some distros still have that annoying feature enabled by default