Androidx86 in VirtualBox does not boot to GUI


I’m running EnOS with all updates and VirtualBox with the “android-x86_64-9.0-r2.iso” image from installed as guest OS (VM). I start my EnOS with Linux-xen kernel. I tried many different settings for this VM but it never reaches the GUI. It boots to a console only (then the screen of the VM turns black) or - when booting in debug mode with nomodeset and xforcevesa parameters added, the boot process presents me with tons of messages like this:

audit: rate limit exceeded

I have no clue what this is about and would appreciate it very much if you guys offered me some hints how to proceed/what to test. Thank you so much! :smiling_face:

I looked into waydroid and anbox, too, but none of them worked for me either.

Did you try enabling/disabling 3D hardware accel? Did you try different graphic drivers(on virtualbox)?
Can you assign more memory to VM? Is virtualization support enabled in firmware?

Can you try again with the normal kernel?

1 Like

There’s a page specifically about running Android-x86 in VirtualBox over here:

1 Like

Toggling 3D acceleration, switching gfx drivers and all combinations did not help, nor did assigning the maximum gfx memory (128 MB) to the VM. Virtualization itself is enabled in the host OS BIOS (Intel board) but if you refer to the guest’s/VM’s BIOS, I have not yet checked. For virtualization in VB’s settings I selected KVM (according to some recommendations provided elsewhere), but I shall try others, too. And yes, I tried also the normal kernel but without success.

Then I setup VB in Windows 10 (Pro, 64bit), created the same “Android” guest VM with the same settings as under the EnOS host and could boot into Android. That does not help much but at least assures me that in principle it works - and should work under EnOS, too, I hope.

My bad that I have not seen that before - thanks for the hint. I’m going to study this, too.

PS: Ah, that page is about installing android-x86 in VirtualBox mainly with Windows as host OS, and I already know that this works. So I’m back to square one, trying to get this up and running on Endeavour OS, too.