Anaconda is an Amazing Installer

So I’ve been using Fedora as of late, and I just wanted to share some thoughts regarding the live installer.

It is possibly the best installer I’ve used for a Distro. It can be as simple or as complicated as you want and can do most anything you want/can script it to do.

The single feature that sold me on it is the ability to setup any Mount point you want during install. I have 4 drives I set to certain mount points. Normally I do the install setting root, home, efi, and swap. Then I chroot into the install and setup my additional mounts before booting the system. Anaconda let’s you do this easily, all from a GUI, AND it handles BTRFS raids like a champ.

If you haven’t, just test it out in a VM. Its really a joy to use even if Fedora can be a pita. I’m assuming its Fedora/RHEL specific and that’s why nobody else seems to use it.

You can do the same using Calamares - manual paritioning

Not sure if you saw this news from Jan.2022, but Anaconda is going to be getting a rewrite in the future. Personally, my favorite installer is the one PopOS uses, which I think is based off the ElementaryOS installer because I like it’s ease of use, simplicity, and beauty. To me Anaconda has always felt like a relic from earlier Linux days, but function-wise I’ve never had any problems with it.

I have a simple use case for my laptop, so I don’t need anything fancy with an installer. Anaconda does the job well and quick with minimal steps, so I’d give Anaconda a 4 out of 5 :star:

It’s funny I see this post just now, I actually installed Fedora 36 over the weekend on my laptop, and after fixing a few nvidia quirks and adjusting some configs, Gnome is running smoother than I’ve ever had it. Fedora is doing some sort of voodoo magic or has bewitched me because I think once I’m done testing it in a week or two, I just might stick with it! :blue_heart:

2 Likes

Fedora doesn’t offer to setup hibernate. No good for me. If I’m using an easy installer, it needs to be easier than that for me.

Good distro. Better for desktops than laptops though imo.

I assume that’s a limitation of anaconda since it also ships with both Bluetooth enabled and even my printer just worked right out of the box, so it can’t be a security issue as those wouldn’t be included if it was.

1 Like

You cant do any random mount point you want last time I installed EOS a few months ago. Calamares let’s you select /,/home,/boot,etc. but not type anything you want.

Unless they added that recently?

Looking at its documentation I’m not so sure. It might just be a choice on redhats part because hibernation can be hit or miss depending on hardware but suspend is usually OK.

Its seems to be able to do just about anything you can script.

It’s a pretty poor choice and decision in my eyes, but I live in pacmanland, so to each their own I suppose.

If that’s not a limitation of anaconda but a limitation if Fedora, then I’m with you. Their installer is great otherwise.

Just needs hibernate.

If I’m going to use an easy installer instead of The Arch Way, I don’t want to have to do setup after I do setup. I hate double work.

I’ll have to test that one out, I’m not so worried about beauty as much as functionality :stuck_out_tongue: if it can do arbitrary mount points that’s an A+ in my book.

I’ve had a good number of systems that when they enter hibernation they would refuse to wake. This is across many years and different hardware/vendors so its a sensible choice to me personally. I don’t use it because its never worked reliably for me.

1 Like

In all the different computers I’ve had/fixed/sold in the last few years I’ve never had an issue ever with it.

I’ve also never had Nvidia, so it could be on them. Anyway, no more off topic.

For me its SELinux, as I’ve got older I’ve gotten more paranoid and RH has put a lot of work into setting the policy for it on their distros. I simply don’t have the desire to invest the time needed to do it on Arch for my desktop. My (currently broken) laptop will continue to use Arch though because Fedora makes some things an absolute chore to do.

I had to figure out the dependencies and complied PSensor myself, which I obviously can do but why isn’t it in Repo when Xsensors which hasn’t been updated in centuries is? Just getting the hacks my laptop needs going would be awful based on things like that. Something that simple required 100x the normal effort needed, my laptop would take weeks lol

1 Like

Be carefull with that. Another sign that points to it, is that you haven’t yet realized Linux/Arch is voluntary. When I read you are old, I was expecting you take over some packages for maintaining.

Age brings either wisdom, or paranoia, it seems… :rofl:

2 Likes

These are not mutually exclusive concepts, you know…

Just because you’re paranoid, does not mean you’re wrong.

tinfoil

7 Likes

Haven’t used Fedora in ages, but it is no doubt a great distro.

EndeavourOS installer has a feature that is not in calamares: the user_commands.bash script file which will be executed in the end of the install process.
User writes (or downloads it from somewhere) the contents of that script before starting the install process.

That script can do almost anything to the installed system, like

  • install and remove packages
  • add 3rd party repositories
  • make the new system use the Arch testing repos
  • manage grub menu entries, e.g. set the default entry
  • manage systemd services
  • write dotfiles under $HOME for the newly created user

and much much more.

As far as I know, the only limitation is: it is not possible to install packages from the AUR.
But maybe we can find a solution for that as well in the future. :wink:

3 Likes

With suitable warnings put in place?

You can do any mountpoint you want. It offers the most common mountpoints but you can type anything you want there.

There is no doubt it’s partitioning tools are powerful. Especially the blivet-gui. However, there is minimal other configuration available and it is wildly unintuitive.

From a usability perspective, it is the worst GUI installer I have ever used.

2 Likes

Im curious what you find unintuative about it? what do you feel is missing?

Ive tried this numerous times with calamares and it has never let me type anything for the mount points, only select per-defined ones. is this a recent addition?

Yes you can - Calamares has always supported creation of arbitrary partitions and assign those to arbitrary mountpoints.

You don’t have to select any of the preloaded choices - you can just write your own mountpoint e.g.

/data/docs
VirtualBox BIOS/GPT Install Screenshots

Installer partitioning

Final result

1 Like

Im curious why this hasnt ever worked for me then, in EOS or Manjaro when i would type in the mount point it wouldnt assign it. Ive tried at least a dozen times over the past couple years to do so. Thats why i even do my chroot into the system before boot :thinking:

Yes, the “template” file at /home/liveuser/user_commands.bash includes information about this limitation.

1 Like