AMDVLK issues with lots of Steam games

Hi, I’m writing here because I have a friend who is not a linux guru and he stumbled upon a lot of issues with Steam games with his AMD GPU. He says that a lot of these games just crash (maybe one time they work and other times they do not). He uses both native games and games running under Proton…

I then tried to troubleshoot its setup and I’ve found out that EndeavourOS uses AMDVLK by default…
So I had to remove amdvlk and install the vulkan-radeon package and relative libraries… Then, those games started to work…

Given that Valve itself uses RADV for its Steam Deck (and I use raw ArchLinux with RADV and I have no issues), and nowadays RayTracing is supported on RADV as well, is there any reason AMDVLK is the default driver for Vulkan for AMD GPUs in EndeavourOS?


Where do you see that as the default? I didn’t think we installed vulkan support by default.

When you install Steam it automatically installs vulkan as a dependency. The user is provided a choice between between amdvlk and vulkan-radeon, with amdvlk being the “default” for no reason other than “a” being the first letter on the alphabet, although vulkan-radeon is noted to provide much better performance. However, an uninformed user is likely to select the default option.

1 Like

That has nothing to do with EOS though. In fact, EOS does not install anything by default, as far as I’m aware and as you mentioned, you get to select stuff.

As seen in the Arch Wiki:
For Vulkan support:

So the default is set by alphabet, and considering is a prompt from the Steam package, I am not sure EOS devs could change that.

1 Like

Can confirm: I’ve installed EndeavourOS on a libvirt VM and by default there’s no amdvlk and no vulkan-radeon package installed.
Tried to install steam and it offered to install a package to provide vulkan-driver with amdvlk as choice number 1 (so the default)…

So I just have to tell my friend to not install amdvlk next time and choose vulkan-radeon:sweat_smile:
Sorry for the disturb…

Maybe to increase the experience for new users, vulkan-radeon and other vulkan packages like vulkan-intel have to be installed by default (like it is for OpenGL mesa)? Vulkan is indeed nowadays a common graphics API (especially for games running under Proton)…



I agree it’s not an EOS-specific issue - I was just offering an explanation for what OP and OP’s friend were experiencing.

1 Like

Use vulkan-radeon!

1 Like

Don’t worry! Instead, you should celebrate that unlike me they didn’t seem to have issues with the multilib version of Steam making them use the Flatpak instead.

This has been talked about EOS team: This distro isn’t meant to accomodate new users with hand-holding solutions, GUI, etc. It’s meant to succeed Antergos, and in that essence, be an “easy approach to base Arch”. Or at least that’s how I understand it. And with that into consideration, Arch is Arch. It’s not really meant for simple/novice users.


I agree - not everyone needs vulkan so it shouldn’t be installed by default.

I’m not even running games and i still install everything related to amdgpu to make everything work. Just in case! :wink:

1 Like