Amdgpu-experimental

Tried installing this package from AUR

It does work with stock Arch.

I tried in RebornOS and it has the same error.

$ yay -S amdgpu-experimental
:: Checking for conflicts…
:: Checking for inner conflicts…
[Aur:1] amdgpu-experimental-2020104-1

1 amdgpu-experimental (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: PKGBUILD up to date, Skipping (1/1): amdgpu-experimental
1 amdgpu-experimental (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: (1/1) Parsing SRCINFO: amdgpu-experimental
==> ERROR: install file (endeavouros.install) does not exist or is not a regular file.
error downloading sources: amdgpu-experimental

moved to general system, not a BUG as AUR builds are not developed by EndeavourOS :wink:


but indeed this is strange:
==> ERROR: install file (endeavouros.install) does not exist or is not a regular file.

This package only consists of config files which set the following options:

# Enable experimental hardware support in generall
options amdgpu exp_hw_support=1

# Enable amdgpu for Southern Island (SI) generations
options amdgpu si_support=1 
options radeon si_support=0

# Enable amdgpu for Sea Island (CIK) generations
options amdgpu cik_support=1 
options radeon cik_support=0

# Enable experimental hardware support in generall
options amdgpu deep_color=1

I think you can just set these options manually.

because of this?

install="$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install"

The package doesn’t seem to come with any install file.

2 Likes

it reads install="$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install" what is unneeded and strange as it will only work on archlinux and the file already is called archlinux.install

changing to install=archlinux.install should work

and this file is there:

2020-10-14_20-59

1 Like
# Maintainer: Fabian Bornschein <plusfabi[AT+thegoogleadress]>

pkgname=amdgpu-experimental
pkgver=2020104
pkgrel=1
pkgdesc="Enables experimental features for AMDGPU"
arch=('x86_64')
url="https://gitlab.com/Fabish"
license=('Apache')
depends=('systemd' 'linux' 'mesa>=20.2' 'vulkan-radeon')
install=archlinux.install
source=("91-amdgpu-experimental.hook"
	"91-amdgpu.deep_color.conf"
	"91-amdgpu.exp_hw_support.conf")
sha512sums=('763469b1530ba744a1155418e0ce4e17c70f658f8a425aa11f57627d86963511c4534e2722fa4a14abf6eff64a8957695bd995e05dfd0487d1ac89917dd93911'
            '4cbb7ffc42cb0a251ed15465dbc037cf5dba88aed0e220802f5d77d652abd4045e35d295b5b3a56d2150add21a66e304ee93cb57b93df0aca2d9f71d5c22ae8a'
            '651fc2269bf583bae4357a3c1a12a1391506ae1e55be1b37e75725596e875dee0ef4d7e064363449ffa39c4276071db4e6d20fbf212682f74056de5ab3576bdc')

package() {
    # CONTENT
    cd "${srcdir}"

    # Install contents
    /usr/bin/install -D -m644 "${srcdir}/91-amdgpu-experimental.hook" \
    	"${pkgdir}/usr/share/libalpm/hooks/91-amdgpu-experimental.hook"
								
    /usr/bin/install -D -m644 "${srcdir}/91-amdgpu.deep_color.conf" \
        "${pkgdir}/usr/lib/modprobe.d/91-amdgpu.deep_color.conf"
    	
    /usr/bin/install -D -m644 "${srcdir}/91-amdgpu.exp_hw_support.conf" \
        "${pkgdir}/usr/lib/modprobe.d/91-amdgpu.exp_hw_support.conf"
}

I didn’t think it was necessary to rebuild an initramfs after setting a module option as those files were read on boot? :thinking:

Maybe it’s for the case where you insert the modules into the initram?

as @anon31687413 pointed out, it’s because of the line

install="$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install"

That checks the last part of the last line in /usr/lib/os-release and uses this as filename for the install file. Since I only ship an “archlinux.install” it will only work for archlinux, or distros who do use the archlinux logo file or have a workaround for this.

This is intended, since I only want to support what I can test.

You can change the line to

install="archlinux.install"

and it could work. Would be nice to have some feedback so I could put in an EnOS install file and make it just work.

6 Likes

Welcome to the forum! Thank you for stopping by and assisting with this :+1:

2 Likes