AMD Ryzen 7 5800H HP Victus set higher CPU voltages

I have HP Victus laptop with AMD Ryzen 7 5800H CPU inside.

It experiencing random reboots - power offs on light load. Probably this - https://bugzilla.kernel.org/show_bug.cgi?id=212087

I am using KDE with power-profiles-daemon - that now support AMD Auto EPP driver.
System stable on power and balance_power energy performance preferences, time to time reboots on balance_performance and very often reboots on performance.

Apparently Widows driving this CPUs at higher voltages (on Win laptop appear hotter and louder for sure)

And suggested fix for this is to - “set Curve Optimizer to +4/+8 on all cores”. But, HP bios do not expose anything beyond boot options.

So, my only question for now - how can I somehow increase CPU voltages without bios settings?
I tried to use Smokeless_UMAF but did not find where I can increase CPU voltages there.

I personally don’t think you would want to do this. Have you checked if there is a newer UEFI Bios update?

I tried almost everything already.
It is known problem, I didn’t saw reports about BIOS update fixing it, and I have latest available bios.

Are you using amd pstates?

https://bbs.archlinux.org/viewtopic.php?id=291561

Edit: This is mainly about the heat issue to start.

Edit: Also

https://www.reddit.com/r/AMDHelp/comments/177mby1/linux_amd_pstate_epp_scaling_driver_on_amd_ryzen/

Edit: Higher voltage is only going to give you more heat!

Edit:

No. It is happening only on idle. Under any substantial load this is not happening. Temperatures is low (45C).
And it is not happening with Windows.

Yes. I tried in active and passive mode. Same problem.

In active mode it is always happening on performance power preference. I can reliable reproduce it by leaving Firefox playing YouTube Mozart music in background (and not touching laptop), laptop powers down in around 7 minutes.
On balance_perfomance - it is happens sometimes. On power preference - almost newer.

To be sure I recorded frequencies and temperatures up to moment of shutdown:

hp-isa-0000
Adapter: ISA adapter
fan1:           0 RPM
fan2:           0 RPM

BAT0-acpi-0
Adapter: ACPI interface
in0:          17.08 V  

zenpower-pci-00c3
Adapter: PCI adapter
SVI2_Core:     1.44 V  
SVI2_SoC:    950.00 mV 
Tdie:         +42.1 C  (high = +95.0 C)
Tctl:         +42.1 C  
SVI2_P_Core:  15.22 W  
SVI2_P_SoC:    5.59 W  
SVI2_C_Core:  12.52 A  
SVI2_C_SoC:    5.89 A  

amdgpu-pci-0600
Adapter: PCI adapter
vddgfx:        1.45 V  
vddnb:       943.00 mV 
edge:         +38.0 C  
PPT:          13.00 W  

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +42.0 C

and cat /sys/devices/system/cpu/cpufreq/policy*/scaling_cur_freq output:

3491655
3341453
400000
400000
3169123
400000
4181401
400000
3586263
400000
3409788
400000
400000
400000
3167984
400000

Recorded with 1s interval until error. I don’t see any abnormalities.

This is both my posts :melting_face:

Going to balance_performance - do not solve problem completely.

I didn’t even realize it was your posts on Reddit. So you don’t have the overheating issue just shutting down when idle or low load?

Yes :blush:.
Something very strange happening. I have my suspicions, and on kernel.org someone wrote similar thoughts, probably something related to transition from lover P states (or wise versa?).

I am fighting this problem for some time already. I sort of find workaround (so I can use powersave profile if I really need to) but this is not a solution.
So I started new round, now trying to find a way lifting voltages a little.

@Nyan
Have you tried any kernel parameters such as

acpi_osi="Windows 2011"

amd_iommu=off

@Nyan
What about CPPC in bios?

Yes I did.

I also tried fiddling with GPUs power.

I have feeling that to 89% I isolated problem to CPU power management…

I tried different Linux distributions as well. Fedora Ubuntu PopOS! - same thing.
And, I don’t really remember, but I have the feeling, that I tested this without loading X11 or Wayland.
Yes, both on X11 and Wayland - the same.

I had suspicions for some time that this is somehow related to video playback, but, it seems it is not.
Just watching movie is what makes prolonged low load.

HP Bios do not expose anything. It is really basic.
I am trying to figure out what can I do from Smokeless_UMAF utility - https://github.com/DavidS95/Smokeless_UMAF


I see CPPC exposed thru Smokeless_UMAF, but not sure what to do with it, it defaults to auto:


Try disabling CPPC

Disabling CPPC leads to Linux using acpi freq driver for scaling. Problem stays, laptop powers off on idle.

Disabling preferred cores - problem stays.

Changing cpu power limit to 45W - problem stays.

I can’t change the hardware. It is what it is. :man_shrugging:

Ok. I finally solve it!
The way to do it is to disable C6 state. I did it with https://github.com/r4m0n/ZenStates-Linux
Like this: sudo python zenstates.py --c6-disable

Happy you got it resolved. :smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.