AMD Radeon - Gamma

I’ve just switched from an nVidia RTX3070 to an AMD RX 6700XT. I had a variety of settings I used with nVidia to support visual impairment (low vision). While high contrast works, I’m having trouble finding a way to set gamma levels correctly.

Previously I’d set the below to autorun at boot in a script ;

nvidia-settings -a 0/RedGamma[DP-0]=0.644000 -a 0/BlueGamma[DP-0]=0.644000 -a 0/GreenGamma[DP-0]=0.644000

Is there any way I can do the same with AMD? I’d switched for the easier experience with open-source drivers, hopefully gamma’s an option, even via cli. Appreciate the support!

[Edit with a potentially clunky resolution]
So I’ve dumped an xrandr command to replace the above, it’s clunky but does the job until I can get Gamma to work in Wayland :

xrandr --output DisplayPort-2 --gamma 0.644:0.644:0.644

I would first check if you DE supports it. For example, plasma has built in controls for setting gamma levels.

If not, check out tools like xgamma and redshift.

That’s the weird thing, KDE Plasma isn’t showing anything for gamma in settings: I’m not sure if I’m missing a pre-requisite, it’s a fresh install of EOS.


Are you using X or Wayland?

I have the same GPU as you and I see them on X11.

echo $XDG_SESSION_TYPE shows X11 (I don’t think it’s possible to easily set gamma in Wayland yet… I haven’t fully looked at colord profiles).

Here is what I am using for drivers:

pacman -Q | grep -E "mesa|amd|radeon"
lib32-mesa 23.1.4-2
lib32-vulkan-radeon 23.1.4-2
libva-mesa-driver 23.1.4-2
mesa 23.1.4-2
mesa-utils 9.0.0-2
mesa-vdpau 23.1.4-2
vulkan-radeon 23.1.4-2
xf86-video-amdgpu 23.0.0-1

Thanks, that’s really helpful to troubleshoot. I’m showing the below, so it looks like I’m missing a few components, thanks for pointing me in the right direction,

amdvlk 2023.Q2.3-1
lib32-amdvlk 2023.Q2.3-1
lib32-mesa 23.1.4-2
mesa 23.1.4-2
mesa-utils 9.0.0-2
xf86-video-amdgpu 23.0.0-1

Covering off the missing packages didn’t bring anything back to Plasma settings for gamma after a reboot, but I think the xrandr option will suffice for now.

Final update : Looks like kgamma5 is missing from the latest EOS iso, - installing that resolves the issue.

1 Like

On a positive note, replacing amdvlk with radeon-vulcan should help if you use vulcan for anything.

Also, the vdpau and libva drivers should give you hardware decoding for video.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.