AMD/Nvidia card priority, NOT hybrid (SOLVED)

I have a 6900XT and a Quadro P4000.
For the life of me I cannot get the OS to prioritize the AMD card, and everything just runs on the Quadro.

How do I get it to stop doing this, and just default to the AMD?

Hello @Cerberus
Is it possible to give the hardware info first of all. What type of laptop is it make and model. I’m assuming it’s a laptop? Post the url for the hardware output.

inxi -Faz | eos-sendlog

It’s a desktop. it’s not a hybrid solution, it’s two dedicated GPU’s.

It’s showing that it is rendering from the AMD graphics.

API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon RX 6900 XT (navi21
    LLVM 15.0.7 DRM 3.49 6.2.10-arch1-1) direct-render: Yes

Why do you think it’s using the Quadro P4000?

Yes, I wasn’t sure by the title what you meant. :wink:

Because every game I load, mangohud shows the P4000 in use, and there’s zero load on the 6900 when I look at corectrl.

Horrible workaround: Move /usr/share/vulkan/icd.d/nvidia_icd.json somewhere away from that folder.
Force RADV driver with this:
Also an internet search brought up this:

1 Like

I’m not sure if you can use one of the methods that are used with Hybrid setup?

In my Lenovo Legion firmware I can flat out turn off the switchable graphics which then uses the dgpu always. . .

So, basically I’m saying, check out your firmware.

Can you blacklist nvidia and nouveau?


I was going to suggest that too. Not sure why the OP wants to use both Gpu when the Radeon 6900XT is over 200% better. :thinking:

It’s neither a laptop, not a hybrid setup.

Nvenc and CUDA.

Does it have to be an 8 gig quadro? No. that’s just what I had sitting around that fit in the case.

I was just wondering why you don’t just use the Radeon card on it’s own? :innocent:

It has neither nvenc nor cuda, both of which I need.

I don’t plan to use the quadro for anything other than a processing unit, but for some reason it’s not only grabbing priority, but it’s also feeding video through the AMD.

Followed the ENV modification advice in there, in my case I had differing files, as expected:

l> s /usr/share/vulkan/icd.d/

./ …/ amd_icd32.json* amd_icd64.json* amd_pro_icd64.json nvidia_icd.json

so I edited my /etc/environment and stuck this on the bottom and rebooted. (there was no VK_ICD line to begin with, for clarification.)


All is right in my rig once again thanks to you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.