AMD not compatible with Linux?

Gigabyte B550, Ryzen 5-5600

Ok, here’s the thing:
No matter the system, EOS, Manjo, Sparky (Debian Sid), everything works great for a couple days, then one fine day I get weird messages (missing IRQ handler?) during startup but system works fine, no probs. Couple days later small probs do occure, like calendar gone from task bar, refuses to show up again, bookmarks not showing, lots of wonky things, can’t save stuff …

That was in Manjaro.
Then tried Sparky, was happy hippo. After, like 2 weeks the same shit started happening again. :frowning:

Switched operations over to a Lenovo SFF ThinkCentre - NO PROBLEMS!!!
EOS on Clevo laptop - NO PROBLEMS!!!

Lenny and lappy both Intel machines.

Friend tells me the B550 chipset doesn’t work with Linux. First I thought it’s my Gigabyte mobo and maybe I should switch to Asus. But friend tells me they’re all using the same AMD chipset. :roll_eyes:

What are your experiences with AMD/Linux? Is there anything I can do to remedy the situation?

In general AMD works very well on Linux. That is not to say that there might be specific issues with that particular mainboard or chipset (I have used AMD for years now without any major issues, but I never had a mainboard with a B550 chipset).

Did you try upgrading the BIOS/UEFI of your mainboard yet?

2 Likes

This sounds like a hardware issue, and not in the ‘amd incompatibility’ way, more like corrupted RAM, storage or maybe a faulty motherboard kind of way.

I’m on AMD Ryzen 6900hx. besides a few tpm issues (stutters caused by tpm, damn garbage spyware chips) that were fixed i believe around kernel 6.4, it’s been flawless. the iGPU as well.

1 Like

I have been distro-hopping for the past two years on an MSI B550 with a Ryzen 5600x with zero compatibility issues, and that is across probably 30+ different distributions whether they were Arch, Fedora, SUSE, or Debian based.

I did a quick google search, and on the linux mint forums and askubuntu people are saying the solution is a BIOS update as this was a problem specifically with B550, and one person asking about it also had a gigabyte board.

4 Likes

Thx very much. You guys are the bestest! :kissing_heart:

Machine was at Gigabyte workshop, they just said I must never use Linux. No probs with Windows. I assume they had updated the BIOS but you can never be sure with these people.

Gonna try now to update the BIOS. No idea how to but gonna find out soon I guess. :crazy_face:

FYI - it is and does and has been working great with no issues for almost ayear. I’m on a B550 board with Ryzen 9 and AMD GPU. . .


Host: B550 Steel Legend 
CPU: AMD Ryzen 9 5950X (32) @ 3.4GHz [36.1°C] 
GPU: AMD ATI Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT 
               

2 Likes

From experience I can recommended Asrock boards for AMD on Linux. They generally work well and even fix Linux specific issues in their BIOS updates occasionally instead of telling you to just use Windows.

Gigabyte on the other hand is, well just “a bit shit in general”, for a lack of better terminology.

2 Likes

Years ago I was told Gigabyte is the bestest. Had already probs with it and Intel cpu. Dunno why I went for them a second time. :thinking:

:man_facepalming: for Gigabyte workshop saying “never use Linux”

inxi -b should show your Motherboard / BIOS version

If problem will appear again you can check latest entries in logs: journalctl -r

And also exact content of weird messages would be more than helpful.

1 Like
Machine:
  Type: Desktop System: Gigabyte product: B550 GAMING X V2
  Mobo: Gigabyte model: B550 GAMING X V2
   UEFI: American Megatrends LLC. v: F18 date: 03/22/2024
CPU:
  Info: 12-core AMD Ryzen 9 5900X [MT MCP] speed (MHz): avg: 2022
    min/max: 550/4951

Wonky donky for the first updates of the firmware… and still some wonkiness like it removes nvram on every firmware update… and fan settings GUI part is the most wonky interface you can think of. Each time i want to change something there i am confused like someone never opens Bios interface before…

But It’s what a knowledge guy said once:

No, seriously, they are all bad. There isn’t a single consistently reliable and reputable one. Unfortunately, you have to buy one of them.

2 Likes

I’m running a B550 chipset on MSI motherboard and 3700X Ryzen 7 cpu. No problems ever. Updated to latest bios. . . still no problems. No problems what so ever. Everything works.

Rich;)

1 Like

If they told me this, I’d say that it sounds like I’d just never use Gigabyte lol.

4 Likes

such universal beliefs – and the world goes round and round nonetheless

1 Like

It’s a really common theme in the world today unfortunately. All day everyday everywhere. From mainstream media, TV, movies and even here.

That’s life in 2024 it seems.

1 Like

I think they were confused with Windows. :sweat_smile:

2 Likes

Capture d’écran_2024-06-05_21-19-24

3 Likes

Machine:
Mobo: Gigabyte
Model: B550I AORUS PRO AX
UEFI: American Megatrends LLC. v: F19 date: 03/22/2024

Works like a charm.

1 Like

ASUS Prime B-550 Plus, Ryzen 5600G, Radeon RX 6650 XT .
No problems at all with this setup.

I used a Gigabyte/Intel system for the past couple of years initially with ArcoLinux then EOS, never had a problem. My latest build is ASRock/AMD B650 and has run EOS without fault since day one.

As others have mentioned, you may have a fault somewhere rather than an AMD/Linux incompatibility. I remember one issue I had in a build where the RAM needed a bit more voltage (+0.2v?) than default to be stable. Once I figured this out all was sweet.

1 Like

B550 should work just fine. Sounds like some kind of hardware failure (bad RAM, bad CPU, bad memory controller or even drive failure)

Start by updating your bios and then test with XMP disabled.

1 Like