AMD FidelityFX (FSR). How to get it working?

Long story short

  • Open up steam
  • Have the latest proton-ge installed
  • Made sure all my games use Proton-ge
  • Use “WINE_FULLSCREEN_FSR=1 %command%” variable on steam launch options for each game
  • Boot game
  • Decrease resolution from 1080p to 720p
  • Game crashes

I want to mention that I had the nvidia drivers installed and working properly, same for Mesa drivers and proton-ge.
Using an laptop with an I7 for cpu and gtx 800m series card NVIDIA.
I would like to know if there is a solution for making FSR work in Linux.
This issue also occurs on distros such as Pop_OS (couldn’t test on fedora as it doesn’t boot when I install the nvidia drivers for some odd reason. Maybe I can give Nobara a try?)

Maybe I am a silly Turkey and this whole FSR thing doesn’t work on nvidia card like mine?

The environment variables have changed. See this release notes:

I mean I use wine_fullscreen_fsr=1…That is not good or?

There are a few more parameters to fine tune FSR.

Well yeah. But the problem I have is that FSR CRASHES my games.

It works on any modern GPU (Gtx 700 + I.E)

What games? What DE? Wayland or X11? I’ve tested it working on everything from a HD 7870 1gb → 5700xt personally. I know it works on 1060 and 980 for nvidia.

800m is all maxwell and newer AFAIK so while it may be crashing when enabling FSR that doesn’t mean its FSR causing the issue. Do you have any logs or anything?

Correlation doesn’t equal causation, plenty of nvidia users play with FSR just fine so IMO its not FSR but something specific to your setup. You have no proton logs or anything here so can’t say what could be happening. There simply isn’t enough info to troubleshoot your issue.

Are you using Wine desktop? It needs to disabled.

I tried with games such as Unturned, Half life 2 and Metal Gear solid V. The DE was gnome on X11.
Yeah i am not sure what is wrong with my setup. Maybe because I ran the OS using nvidia only instead of hybrid mode? (Optimus manager on Endeavour, system76-power on pop_os)

Well get some proton logs

Its better to get logs than stab in the dark randomly :joy:

You nor anyone else are likely to guess the reason at random.

1 Like

Sure, no worries! Give me a few hours and I will get the logs.

From GE’s 7-25 release:

Usage remains the same:

WINE_FULLSCREEN_FSR=1 WINE_FULLSCREEN_FSR_MODE=ultra %command%

Modes available:
ultra - ultra quality
quality - quality
balanced - balanced
performance - performance

For reference, here is the formula used by FSR in case you want to make your own modes for different aspect ratios:
Ultra Quality — 1.3x scaling
Quality — 1.5x scaling
Balanced — 1.7x scaling
Performance — 2x scaling

You can still alternatively use a custom mode as well:

WINE_FULLSCREEN_FSR=1 WINE_FULLSCREEN_FSR_CUSTOM_MODE=3938x1108 %command%

As noted -- you must set the in-game resolution to either the ultra resolution added or the custom mode you provide, and set fullscreen mode.
The game will then up-scale that resolution to your screen's real size.

Try adding the mode command (WINE_FULLSCREEN_FSR_MODE=ultra - or any other mode ofc) as well. Perhaps then it will work.

Anyway, a lot of people are complaining regarding FSR issues with his latest releases.
He has pinned the following message in his Discord:
image

2 Likes

It works now. Thank you!

1 Like

You’re welcome. Glad it worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.