Am I blind, or is there no way to download EndevourOS on the website right now?

I feel incredibly dumb right now, I’ve been looking all over for either the link to the mirrors or the torrent magnet link and I feel like I am going crazy because as far as I can tell, there is no links to download. I see the links to download EndevourOS ARM and the headless server, and I see the blog posts about Galileo, and in that article at the bottom it just says " You can download the ISO through our magnet link or through a mirror near you on our homepage." and I just don’t see it anywhere on the homepage. I don’t see a dropdown at the top with it, I don’t see a link at the bottom with it. I’ve gone to the installation page and don’t see it anywhere on there either.

I’ve installed EndevourOS before and I don’t remember having any trouble finding the download button.

Here is a picture of what I am seeing on the website. I feel like maybe there’s some sort of maintenance going on because the news dropdown doesn’t seem to work and there seems to be missing icons that I think are supposed to be arrow buttons on the scrolling banner thing?

The website seems utterly broken right now.

Ok, so I’m not a complete idiot, good to know. lmao

Anyone have the direct link to the magnet link or a mirror? Preferably US based if it’s a mirror


Are you trolling me?

Not deliberately…

As far as I can tell, that magnet link doesn’t work

It worked for me.

Maybe it is malformed. Try copying and pasting the link into your torrent client. If not, I can get you an ISO link.

Here is a US link:

Thank you for the mirror link. I was unable to click on the magnet link, and right clicking the link gave me no option to copy it or anything. Tried in both firefox and chrome. All good now though with that mirror link. thank you!

Hei… i think w efixed the webside… could be it was ne try checking some thing there, the slider arrow thing… what is broken:
Now it looks at least same as before i think… main side with all download options is showing up again.

Just in case you can find links here:

1 Like

Just checked and the download section of the website is working for me now, I had already grabbed the iso from the mirror that dalto linked to, and I’ve now already installed the OS and everything, but thank you for fixing the site!

Just an FYI, it does look like the news drop down still doesn’t work, and the parts that I think are supposed to be arrow icons still show like a placeholder texture or something.

yes i see the issue with new menu… it still works as a link to news page.
The issue with the non showing arrows is there for longer already…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.