Alsa not working

alsa only occasionally works

5.6.14-arch1-1

extra/alsa-utils 1.2.2-1 [installed]
    Advanced Linux Sound Architecture - Utilities
systemctl status alsa-restore.service
● alsa-restore.service - Save/Restore Sound Card State
     Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static; vendor preset: disabled)
     Active: inactive (dead)
  Condition: start condition failed at Wed 2020-05-27 08:15:52 CEST; 6h ago
             └─ ConditionPathExists=/var/lib/alsa/asound.state was not met
Condition check resulted in Save/Restore Sound Card State being skipped.```
systemctl status alsa-state.service
● alsa-state.service - Manage Sound Card State (restore and store)
     Loaded: loaded (/usr/lib/systemd/system/alsa-state.service; static; vendor preset: disabled)
     Active: inactive (dead)
  Condition: start condition failed at Wed 2020-05-27 08:15:52 CEST; 6h ago
             └─ ConditionPathExists=/etc/alsa/state-daemon.conf was not met
systemd[1]: Condition check resulted in Manage Sound Card State (restore and store) being skipped.

This is the result I obtain from the systemctl status alsa-state.service command:

The sound on this computer works perfectly.

Do you have the GNOME ALSA Mixer program installed? If not you can get it by doing this:

sudo pacman -S gnome-alsamixer

This program gives you a full range of adjustments and they’re self-explanatory. It’s worth a try.

Lawrence

Can we step back a little? What is the actual issue you are seeing? Are you sure the issue is with alsa?

@ng0177

This is normal output i assume as it’s the same on mine. As @dalto asked…what exactly is your issue?

Archlinux uses pulseaudio on top of ALSA and so also normally does not need to be setup in any way.
Only in some cases on some hardware it is known that it is needed to use p.e. alsa-restore service to keep channels unmuted e.t.c.

Sorry for the late reply. I have a standard msi board and screen w/ speakers that usuallay works under Linux. The issue is the Dummy Output. I remember having seen proper Output Devices some time ago. I did not temper with Endeavour. Any ideas what to check or search for in journalctl? Thanks.

sudo pacman -S gnome-alsamixer
error: target not found: gnome-alsamixer

How is your computer hooked up to the monitor, HDMI?

In your graphic, between Dummy Output and test is the little down arrow. What happens when you click this? Hopefully more options will appear and HDMI will be one of them.

Pudge

Sorry, I forgot to mention that Dummy is the only option available. Well spotted. HDMI / Displaypot are both not working.

Here are the alsa options I have on my EndeavourOS Gnome install. Don’t know if this will help you figure out if something is missing:

[don@Valhalla ~]$ pacman -Q | grep alsa
alsa-firmware 1.2.1-2
alsa-lib 1.2.2-1
alsa-plugins 1:1.2.2-2
alsa-topology-conf 1.2.2-2
alsa-ucm-conf 1.2.2-1
alsa-utils 1.2.2-1
pulseaudio-alsa 1:1.2.2-2
zita-alsa-pcmi 0.3.2-3

Pudge

@ng0177
Could you try some of these commands and post in this order.

aplay -lL

Next Check
dmesg | grep snd

systemctl --user mask pulseaudio.socket

pulseaudio -k

pulseaudio -vvv

Then:

systemctl --user unmask pulseaudio.socket

Maybe it will reset! :thinking:

1 Like

You are right. Audio works now. I meant to attach the output of your commands but this platform does not let me. So, masking that socket and unmasking it again (after a while) makes it work?

The platform does allow you to post the commands in a number of ways. You can copy and paste contents from a command and put three tild (~~~) characters before and after what you copy and paste. If the output is really large there are other ways to output it to a file and upload it to pastebin. Here is some info for next time.

Has it stayed working for you now and the right output device is listed?

Thanks for asking! It ceased to work after one day w/ reboot in between. We are back to ground zero.

Sorry to hear that. Have you brought up alsamixer from the terminal and see if anything is muted? You can also select your audio device from there. F1 for help F6 to select your sound card. If anything say’s mm it’s muted.

Very interesting: when running alsamixer then the soundcard “HDA Nivida” setting under F6 is not stored. when running sudo aslamixer, then it is. Under Gnome Settings, a user never sees the correct soundcard setting stored as sudo.

So are you able to make any headway?

Unfortunately not. I manage to set it using sudo but it has no effect.

Try deleting the directory and reboot and it will recreate it. It is in the home folder under hidden files.

~/.config/pulse

Success! Problem solved. sudo alsamixer shows what is seen in Gnome Setting and used, whereas alsamixer shows the wrong information (pulseaudio i.e. Dummy which is not working). Thanks for that!

1 Like