All kernels failing to boot

No the computer only boots if I add mitigations=off… I haven’t added it permanently yet.

Did you install the headers?

Okay sorry i misunderstood. I’m finding it strange that my system boots fine except on virtual box.


I missed the word without. :man_facepalming:

No I hadn’t, this is the error I got when I just tried it -

==> dkms install --no-depmod vboxhost/6.1.36_OSE -k 5.10.134-1-lts510
Error! Bad return status for module build on kernel: 5.10.134-1-lts510 (x86_64)
Consult /var/lib/dkms/vboxhost/6.1.36_OSE/build/make.log for more information.
==> WARNING: `dkms install --no-depmod vboxhost/6.1.36_OSE -k 5.10.134-1-lts510' exited 10

No you hadn’t what?

Last night when I installed the linux-lts510, I didnt install the headers.

Well you would need to install the headers for that specific kernel.

1 Like

Removed virtualbox virtualbox-host-dkms, installed linux-lts510-headers. still no luck.


Check the error above, modules were failing to build and the error showed it was vboxhost… so i removed virtualbox for now to see if the kernel headers would build and install. They did but it doesn’t change the outcome with failed boot.

Funny thing is I am sure that this is because of some changes in the recent version. And I thought LTS would be immune to being borked by changes. 5.15.55 worked. it’s still in the cache but I dont know how advisable it is to go back and to stay at that version indefinitely.

I also had this clocksource problem that affects AMD cpu’s, but with the 5.18.15 kernel only.
Kernel 5.18.14 and the LTS booted fine.

I had to add spectre_v2=off to the kernel boot string to fix it.

1 Like

Ahh read through that thread and I am glad I am not the only one… :sweat_smile: Looks like the fix is in the works and I will just temporarily add the mitigations workaround till the next updates…

1 Like

There is a mention of retbleed=off in that thread from ArchForum as well.
Has anyone tried that?

I’ve got:

  Info: model: AMD Ryzen 7 4800U with Radeon Graphics bits: 64 type: MT MCP
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP

 uname -r

It is not hit by this issue on this machine on my end.

I have the same issue since I updated 5.10 last weekend. At first I thought the latest kernel works but after an update it stopped to boot to UI as well.

Screen glitches

Thx for the work-around. It works fine.

I hope they will fix it soon.

Looks like linux 5.18.16.arch1-1 currently in testing should have a fix for this issue:

linux-5.18.16 fixed this bug. Thanks everyone for the help… especially @ricklinux @Kresimir and @jonathon thank you for updating your kernel repo so quickly :slight_smile:

Man I panicked more than any kernel seeing this :joy:

1 Like

I’d suggest that pebcak’s post just above should be marked as the solution.


Jonathons Lts-Kernel 5.10.135 works again fine. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.