Alacritty crash

Hi I have been searching the net like crazy
and can not find anything
Alacritty crashes all the time and I have looked in the config file and can not figure out what is smooth
if there is someone who has experienced the same and may have a solution


cpu info: Quad Core model: Intel Core i7-2670QM
Thanks in advance

Seems like an issue with graphics libraries. Alacritty uses GPU acceleration if I’m right. I don’t have any graphics card to test.

I’d suggest you to update all packages - graphics related specially (mesa, nvidia drivers etc) Then perform reboot.

2 Likes

everything is update
and I do not have nvidia
tried installing xf86-video-intel
but then I could not log in
had to remove xf86-video-intel again
i have tried to counterprove -r i915
but says modprobe: FATAL: Module i915 is in use
i want to try that fashion but don’t know how

Alacritty crashes if your gpu (iHD 2k goes up to 3.1) doesn’t support opengl 3.3 and above you must use cpu for rendering.

LIBGL_ALWAYS_SOFTWARE=1 alacritty
2 Likes

i have try this
It did not help

LIBGL_ALWAYS_SOFTWARE=1 alacritty

i do nano ~/.profile
and i put this line in and i reboot
but after 5 min alacritty crach again

i’m now trying to write it in .bashrc
export LIBGL_ALWAYS_SOFTWARE = 1 alacritty
hope it helps i would rather not get rid of alacritty :slightly_smiling_face:
but thank you very much now I at least understand why this is happening

Edit the alacritty desktop file in /usr/share/applications and change the EXEC= line, you will lose some functionality like opacity.