Again a problem by update (KDE)

:: Paketdatenbanken werden synchronisiert …
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
endeavouros ist aktuell
:: Vollständige Systemaktualisierung wird gestartet …
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (2)           Alte Version  Neue Version  Netto-Veränderung

extra/appstream     0.14.4-1      0.14.5-1               0,30 MiB
extra/appstream-qt  0.14.4-1      0.14.5-1               0,07 MiB

Gesamtgröße der installierten Pakete:  7,85 MiB
Größendifferenz der Aktualisierung:    0,37 MiB

:: Installation fortsetzen? [J/n] j
(2/2) Schlüssel im Schlüsselbund werden geprüft                       [---------------------------------------] 100%
(2/2) Paket-Integrität wird überprüft                                 [---------------------------------------] 100%
(2/2) Paket-Dateien werden geladen                                    [---------------------------------------] 100%
(2/2) Auf Dateikonflikte wird geprüft                                 [---------------------------------------] 100%
Fehler: Der Vorgang konnte nicht durchgeführt werden (In Konflikt stehende Dateien)
/usr/lib/appstreamcli-compose existiert in »appstream« und »appstream-qt«
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

I had already updated the mirrors before.

1 Like

Any chance you could try that again with LANG=C sudo pacman -Syu and post that output?

1 Like

Error: The operation could not be performed (conflicting files)
/ usr / lib / appstreamcli-compose exists in “appstream” and “appstream-qt”
Errors occurred, no packages were updated.

: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
endeavouros is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (2)         Old Version  New Version  Net Change

extra/appstream     0.14.4-1     0.14.5-1       0,30 MiB
extra/appstream-qt  0.14.4-1     0.14.5-1       0,07 MiB

Total Installed Size:  7,85 MiB
Net Upgrade Size:      0,37 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                                        [---------------------------------------] 100%
(2/2) checking package integrity                                      [---------------------------------------] 100%
(2/2) loading package files                                           [---------------------------------------] 100%
(2/2) checking for file conflicts                                     [---------------------------------------] 100%
error: failed to commit transaction (conflicting files)
/usr/lib/appstreamcli-compose exists in both 'appstream' and 'appstream-qt'
Errors occurred, no packages were upgraded.

Could be a conflict from an AUR package that you may have installed? Does pacman -Qo show any errors or no?

pacman -Qo /path/to/file

Edit: ignore this message, I’m still learning as @dalto pointed out :stuck_out_tongue:

Your mirrors are out-of-date. The current version is 0.14.5-2.

It is possible that was a packaging problem that they fixed.

No, not in this case. From the message the issue is that

Those are both repo packages.

2 Likes

@Balder Use the Reflector Simple app (should be installed by default), select your country if its not already selected, sort by Rate, Max number of mirrors 10, select OK, and then wait a moment while it processes the mirrors, then it’ll ask you to save the new mirrors list to your pacman.conf file and save and then try updating again and letting us know how it goes?

OK, have now updated the servers for the 3rd time and now it worked thx @ all :ok_hand:t2:

2 Likes

It is likely that you updated at precisely the wrong time to find that issue before it was fixed. :exploding_head:

2 Likes

Yep, the fix was made only 30 minutes ago:

3 Likes

@Balder, for the future reference, please mark the post which resolved the issue as solution by clicking the three dots under the post and check the box.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.