After update, system performance is slow

It happened to me also this morning. I did this:

sudo pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc

and after that I could update normally. But after reboot my laptop is slow. Boot is slow and also starting programs is slow. So I used timeshift to restore my system to state before update. But what should I do now? There’s no use to update if I get back to slow system again.

Anybody else had this issue?
@mardi did you fix it, or find the culprit?

I haven’t fix it or found any other solution. However, I have Manjaro Xfce unstable installed on other partition and there was no problem. Python-cairo was updated to version 1.23.0-2 without errors and system is fast.

That is almost definitely unrelated to this issue. You should open a separate topic for the slowness.

You mean if I do:

sudo pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc

and after update and reboot my system is almost unusable, that command is unrelated to this issue? Ok, I guess I have to re-install EOS again…

Yes. That command just allows pacman to overwrite that one file. It shouldn’t have any impact on performance. It is more likely something else in the update it causing your issue.

Or you could post a help topic so someone could help you troubleshoot…

1 Like

Are you using testing repos?
I had issues with the testing repos, the system didn’t boot after update.
Reverting to stable repos sorted it. So here it is likely some incompatible update.

+1 for starting a help topic, @mardi
I know its painful, but you’ll help everyone by ironing out the bugs. Do it for the community; Do it for us

No, I’m not using testing repos. Here’s the list of packages that needs update:

[mardi@mardi-82l7 ~]$ yay
[sudo] mardi-käyttäjän salasana: 
:: Päivitetään pakettitietokantoja...
 endeavouros is up to date
 core                  154,0 KiB   157 KiB/s 00:01 [------------] 100%
 extra is up to date
 community               7,2 MiB   493 KiB/s 00:15 [------------] 100%
 multilib is up to date
:: Aloitetaan järjestelmäpäivitys...
selvitetään riippuvuuksia...
etsitään ristiriitaisia paketteja...

varoitus: ei tarpeeksi leveyttä taulukon näyttämiseen
Paketit (15) glib2-2.74.3-1  libreoffice-fresh-7.4.3-2
             linux-6.0.11.arch1-1  linux-headers-6.0.11.arch1-1
             pacman-mirrorlist-20221204-1  poppler-22.12.0-1
             poppler-glib-22.12.0-1  poppler-qt5-22.12.0-1
             python-cairo-1.23.0-2  python-termcolor-2.1.1-1
             r8168-8.051.02-2  sqlite-3.40.0-2  usbutils-015-2
             vlc-3.0.18-4  wavpack-5.6.0-1

Latauksen yhteiskoko:       0,01 MiB
Asennettavan yhteiskoko:  825,45 MiB
Päivityksen yhteiskoko:    -0,87 MiB

:: Jatketaanko asentamista? [K/e] 

I would try updating everything except linux and linux-headers and see what happens.

If it is still slow, it would be helpful to do some further troubleshooting before reverting again.

Hmm. I don’t think the --overwrite option has anything to do with your system’s unresponsiveness. That option basically tells pacman to overwrite the __init__.cpython-310.pyc file and that file isn’t even a system file.

It is more likely that another package that you have updated through sudo pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc that is causing the slowness. Please check your /var/log/pacman.log file to get a list of packages that have been updated recently. This can help you narrow down the exact package that’s causing the slowness.

My EOS system has also been slow since yesterday, although I am/was on the testing repos. In the end, I backed up and reinstalled from iso and now everything is fine again.

They rolled back already. The list of packages is in the above post in the pacman command.

1 Like

I give up. I have fought all day with this problem. During the time I spent with trying to fix this I could have re-install my whole system. I know there’s always that “learning curve” which is useful on the long run, but I decided to save myself from all that trouble… :smile:

Yeah, I reached the same conclusion. I did wonder if it might be a hardware issue, but various test programs showed everything was running OK. I can only guess it was down to one of the various systemd or kernel updates there have been recently on testing.

I didn’t have any issue after running into the same conflicting files during an update. Overwrote the file and it’s all working fine.

On mine it definitely happened before that particular update, although it did have that problem as well.

Maybe I have a different problem with the testing repos.

I tried to update all packages again, and could not get a login window after reboot.
TTY works, so I checked the recently installed files and saw packages
mesa and mesa-vdpau among some others.
Then I downgraded the two mesa packages, and the system worked again.
Also I removed mesa-vdpau since that machine does not have Nvidia graphics. Still worked after reboot.

Then I updated all packages, only mesa showed up, and I continued.
Then the login window fails to appear. So here seems that the mesa package causes this issue.

The machine has Intel and Radeon GPUs, and I have blacklisted radeon, so using Intel.

Here’s inxi -Gxxz link:

EDIT: I just removed package xf86-video-intel and now after reboot the login window appears again! So the latest mesa and xf86-video-intel seem incompatible… (remember: testing repos here)

Nor did I. Updated both my kernels as well, including lts. System runs fine on both kernels.

I did the update on two x86_64 AMD Ryzen based CPU’s and AMD GPU’s and all went well.

I did the update on my wife’s Odroid N2 ARM based computer, and it is really slow.

Now I am afraid to update my Odroid N2 computer I use for ARM Dev.
@sradjoker @Shjim have you done the update on your Odroid N2 ?


Forgot to mention, the two x86_64 AMD Ryzen computers both are running KDE Plasma.
My wife’s Odroid N2 computer is running Budgie.