After update Nvida just now, Steam Games wont play/launch.pls help

I want to try that…how do I change to this driver exactly?

actually says I am using same already? Which kernel are you using?

The default kernel: 6.4.2-arch1-1.

It may be useful to know I use the following launch options:

Be sure to install gamemode and enable it.

sudo pacman -S gamemode
systemctl --user enable gamemoded --now

I had gamemoderun installed and in the launch options already…from the steam tutorial…but I can try your launch options too?


They should work right? because I am not so familiar with launch options…

edit: I tried your launch options …it did seem smoother but it hanged after 5 mins ,…so I might just keep gamemoderun…BTW is there a reason you dont have VKbasalt in launch options?

Everything was working last night. Then today I ran update

yay -Syyu

and then it wasnt launching…


I played for about an hour without any issues.

I didn’t know that launch option existed up until today, so I will try adding it to my launch options. Thanks!

Did you find out what was updated, when you ran that update? Or you could just restore a snapshot of your system if make backups of your system with a tool such as Timeshift?

Have you tried using the Flatpat version yet?

1 Like

I am running the flatpak steam now…just installed it an hour ago…works ok…but as I mentioned I cant see nvdia in AA settings of the game. Which makes me thing the nvida driver has something wrong…

How to find out exactly what was updated when I ran update this morning? I tried search pacman.log but cant find it…I actually used yay to update?

I also had to switch off cloud sync for the game because I was getting sync errors too after the game hanged 20mins ago…the game is running ok now just I dont think it’s fully using the nvdia drivers

I couldnt adjust FPS down to 40 (as others on Steam suggested) so in my system display settings I am running refresh rate from 90Hzd down to 60 Hz now.

How can I check if my current nvidia driver is running correctly?

sudo grep upgraded /var/log/pacman.log | grep 2023-07-08(replace this with the date you upgraded)

Do you see anything with the name “nvidia” listed when you run “flatpak list”?

1 Like

just this from the pacman logs

[2023-07-08T13:13:01+0800] [ALPM] upgraded linux (6.4.1.arch2-1 → 6.4.2.arch1-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded acpi_call (1.2.2-137 → 1.2.2-138)
[2023-07-08T13:13:01+0800] [ALPM] upgraded alsa-card-profiles (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded glib2 (2.76.3-1 → 2.76.4-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded libpipewire (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded pipewire (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded pipewire-audio (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded pipewire-jack (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded libproxy (0.5.2-2 → 0.5.3-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded firefox (115.0-1 → 115.0.1-1)
[2023-07-08T13:13:01+0800] [ALPM] upgraded pipewire-alsa (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded pipewire-pulse (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded mutter (44.2-1 → 44.3-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded gnome-shell (1:44.2-1 → 1:44.3-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded gst-plugin-pipewire (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded iwd (2.6-1 → 2.7-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded lib32-glib2 (2.76.3-1 → 2.76.4-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded lib32-libpipewire (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded lib32-libproxy (0.5.2-2 → 0.5.3-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded lib32-pipewire (1:0.3.72-1 → 1:0.3.73-1)
[2023-07-08T13:13:02+0800] [ALPM] upgraded libwbclient (4.18.3-2 → 4.18.4-1)
[2023-07-08T13:13:03+0800] [ALPM] upgraded linux-headers (6.4.1.arch2-1 → 6.4.2.arch1-1)
[2023-07-08T13:13:04+0800] [ALPM] upgraded linux-lts (6.1.37-1 → 6.1.38-1)
[2023-07-08T13:13:06+0800] [ALPM] upgraded linux-lts-headers (6.1.37-1 → 6.1.38-1)
[2023-07-08T13:13:06+0800] [ALPM] upgraded npm (8.19.2-2 → 8.19.2-3)
[2023-07-08T13:13:06+0800] [ALPM] upgraded protobuf (23.3-2 → 23.4-1)
[2023-07-08T13:13:06+0800] [ALPM] upgraded python-click (8.1.3-3 → 8.1.4-1)
[2023-07-08T13:13:06+0800] [ALPM] upgraded smbclient (4.18.3-2 → 4.18.4-1)
[2023-07-08T14:07:38+0800] [ALPM] upgraded groff (1.22.4-10 → 1.23.0-1)
[2023-07-08T14:07:38+0800] [ALPM] upgraded npm (8.19.2-3 → 9.8.0-1)
[2023-07-08T14:21:02+0800] [ALPM] upgraded python-trove-classifiers (2023.5.24-1 → 2023.7.6-1)

my flatpak list I get this

Name Application ID Version Branch Installation
Steam com.valvesoftware.Steam stable system
Freedesktop P… org.freedesktop.Platform 22.08 system
i386 ….freedesktop.Platform.Compat.i386 22.08 system
Mesa …g.freedesktop.Platform.GL.default 23.1.1 22.08 system
Mesa (Extra) …g.freedesktop.Platform.GL.default 23.1.1 22.08-extra system
nvidia-535-54… …ktop.Platform.GL.nvidia-535-54-03 1.4 system
Mesa …freedesktop.Platform.GL32.default 23.1.1 22.08 system
Mesa (Extra) …freedesktop.Platform.GL32.default 23.1.1 22.08-extra system
nvidia-535-54… …op.Platform.GL32.nvidia-535-54-03 1.4 system
openh264 org.freedesktop.Platform.openh264 2.1.0 2.2.0 system
Adwaita dark … org.gtk.Gtk3theme.Adwaita-dark 3.22 system

edit: Update… definitely something was corrupted with one of the updates. In the end I had to restore from a clonezilla back up I had made a week ago.Will have to reinstall steam flatpak again​:person_facepalming:.

It only looks like your kernel was updated for the rest not much.So now you have working Steam again after having restored a backup from Clonezilla? Have you thought of installing and setting up Timeshift. It will be a lot easier and faster to restore your system compared to restoring a Clonezilla image especially if you are using btrfs as your filesystem?

1 Like

Ya the restored clonezilla image is working fine…Im just scared to update at the moment…I was reading another recent post here that the new lts kernel had created some issues with the amd laptops…including stuck on boot…that happened to me after we chatted here and was last straw for me to restore from clonezilla…

Might wait a bit longer before updating…

I used to have timeshift a year ago but then has some problems I remember it was buggy in my old laptop, I might try to install it again.

I want also ask are these launch codes below you mentioned, specific to your laptop? I dont see any of these mentioned in the steam linux guide (


and btw which proton version are you using to run Dead Space?? proton GE or 8.x.x or experimental??

I was using “7.0-5(com.valvesoftware.Steam.CompatibilityTool.Proton)”, I did refund the game because third-person shooters aren’t really my thing. Maybe I will buy it again when it’s on sale at a lower price.

1 Like

Some others has similar kernel problems recently , i think is related to my kernel problem that wrecked my games Black Screen on Boot Up that Never reaches Login screen - #2 by samac because I couldnt even boot the other day.
I will try install timeshift without upgrading my kernel or system at the moment…because I wanna keep my game for now…
Yeah I prefer 3rd person shooters myself…just my preference…I dont play games much but Dead Space was a great game i played in 2009 on my iphone…it was so great…nostalgic so I wanted play the new 2023 version…

1 Like

I will probably buy it again at some point when it’s on sale because I do love horror/scifi games but it being third-person I just don’t find it worth the full price because I won’t enjoy it as much as I do first person shooters.

1 Like

btw if I install Timeshift with

yay -S timeshift

, its not going to upgrade my kernel is it? Just wanna be sure.

No, that will just install timeshift.

1 Like

Anyhow thanks alot for your help anyway. Good to get help from someone who knows more about linux gaming than I do. Because the Steam linux gaming thread is thin and not much… I think the culprit was the kernel update for my AMD laptop and somehow that affected the game launch. I’ll just stick with my restored clonezilla for now…might try upgrade a week or two later because seems a few people had similar issues to me (AMD laptops with nvidia GPU).

1 Like

No problem! Are you going to be sticking to the Flatpak version of Steam or switching back to the normal Steam pacakge once that is fixed? To be honest I only recently switched to EndeavorOS and I switched to the Flatpak version of Steam and Lutris when I was still on Fedora because I decided I didn’t want anymore 32 bit libs on my system. I’ve never had issues with Steam in the past but I find the Flatpak version of Steam just as good, the only thing the Steam Flatpak can be a bit slow to lauch.

Yeah the flatpak version worked fine but somehow the game i could not set any nvidia settings for AA in game…but I think that was due to corrupted kernel update for me…root of the problem…My clonezilla backup uses the official repositories Steam package and that worked fine before so I will just keep using that for now… yeah its a minor hassel launching steam with flatpak in terminal in beginning but I just created a keyboard shortcut to launch it so that was ok.

I was on fedora before also…and on Ubuntu before that for 10yrs…but now I just prefer Endeavour. I prefer arch based distros and Endeavour seemed the best for me. Overall is more reliable and user friendly and good community for sure.

I don’t launch it from the terminal, the flatpak install creates a menu item which I added to my dash in Gnome. See the screenshot I attached.

1 Like