After update login problem

Today I updated my EOS like every day and and I got notice that: electron (19.0.8-1) breaks dependency ‘electron18’ … or something similar. I solved it with help of this post and update went fine. Update went fine and all works ok except I have a login problem.

When my computer is locked I have unlock screen as usual but when I insert my password instead of loging in I see only my name and picture with a button “unlock” bellow … if I click that button nothing happens and I’m stuck on that screen. If I hit “esc” background image is displayed. When I move a mouse or touch any key then the same unlock button appears. Clicking on it shows the click animation but nothing happens and I need to restart my PC to get into the OS.

Any idea? Is there a key combination in EOS like alt+ctrl+del in Windows to get somewhere and do something?

Did you reboot after your update?

You can get to a TTY with ctrl+alt+f3.

Then login and type reboot

Yes I rebooted after update but always is the same problem. Only first login after restart works. ctrl+alt+f3 opens console and I can reboot it from there.

Weird is that when I insert my password I get that user info and that unlock button which doesn’t work. I can’t get back to login and I don’t have any other option except getting into console.

I didn’t mentioned that I use KDE. I noticed that my display manager is sddm but If I’m not mistaken EOS default should be lightdm? …this probably isn’t related. My other display managers are gdm, lightdm, lxdm and sddm

This is the unlock button I’m stuck with it:

there are some packages removed electron and maybe some others. maybe (re)install electron with the update option

For kde, the default is sddm on EOS. We install a different DM depending on which DE you select.

I tried to update the system but no updates were found and I also tried “sudo pacman -S electron18” but nothing changed.

When I can’t login and I go to console, how I can start DE again and try to login?

If you have only installed electron18, then this has nothing to do with your issue with the lock.

Can you clarify, as it sounds confusing? After you enter your password in the Lock screen, do you get another Lock screen (with Unlock button), or return to the same Lock screen?
Is it possible you have enabled a second (other than default Plasma) Lock screen?

If the password works on SDDM but fails on the Lock screen, it could be a locale problem.
The Plasma Lock screen, gets locale/keyboard layout setting from Plasma session, while SDDM uses system, depending on how you have configured system keyboard configuration and SDDM configuration.

If you can switch keyboard layouts at SDDM screen, and Lock screen, try it to check if there is a difference.

Switch to TTY, login and restart SDDM.

systemctl restart sddm

This appears to be a bug with KDE and multiple monitors (no reported single monitor…yet):

I have this issue, I disconnected second monitor, type password, then at the “Unlock” screen I hit enter (mouse click seems to do nothing), then connect second monitor again. After all that, in my case, I have just disabled screen locking for the time being.

There has been report for single monitor use also:

For both use cases plasma-workspace- is reported to resolve this issue.


Not a surprise at all!!! :joy:

Have you tried this (from the bug report):

when button appears i write my password and press enter and it unlocks, sometimes i need to go to tty and return for it to unlock.

1 Like

After I enter password and hit enter login form slides to the left outside viewport and from the right slides another screen similar to login but without input forms → only with my avatar, name and unlock button which doesn’t work

Yes this is exactly my problem and if I use one monitor then it works. I tried few times to lock it and unlock it and it works. Thanx for the info and I hope it will be fixed soon.

1 Like

@ [haakoth] agree, I also would vote for disable screen locking btw :slight_smile:


This sounds like what Nate had suspected (upstream report), having two lockscreen instances that are not released/unlocked together (when unlocking one of them).
I suppose they are going to fix it soon, since the problem seems understood well from the devs.
Maybe you could add your info/feedback to the bug report. It would both help them fix it and ensure them it is a widespread problem :person_shrugging: .

I added my comment to that bug report :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.