After update internet doesn't seem to work

After an update and switch to xfce from gnome my internet stopped working after a restart, thinking about it, I don’t recall doing anything outside of updating and installing xfce that would have done anything. I tried using usb tethering from android but that also did not work. So I tried looking at guides for getting the internet to work and none of them seem to work.

I don’t know where to start here because the internet is normally not what messes up the computer.

I tried the stuff on the arch wiki but none of it seemed to help at all, the connection tool that came with xfce has everything greyed out. I tried one tool (That I forget the name of) that set it up from the terminal showing that my computer could read and knew it had connections available but just wouldn’t connect it.

I’ve tried everything so now I’m on the live usb and found out how to mount the encrypted drive, any advice?


Are we supposed to read your mind to know which hardware you have?

Welcome @QueenDysphoria

and about your problem , is networkmanager is installed ??
Maybe you have removed it along with gnome . It’s a gnome package .
So boot your system and install networkmanager and restart if it’s not installed

I haven’t updated yet . Will update and see if the update is the problem

Wait, network manager is a gnome package? How do I go about checking if that got removed?
Also I can’t install anything without internet which I can’t get working, I’ll try chrooting (or whatever it’s called)

Welcome to the forum.

The following command will tell you whether network manager is installed.

pacman -Q networkmanager

If there is no output, you don’t have it installed.

However, please post the output of inxi -Fxxxaz.

1 Like

Just start your computer and open a terminal and type
sudo pacman -S networkmanager
( and of course hit enter )
this will install it . This package will be in cache .So you won’t require internet .
Removing gnome will most probably remove networkmanager ,as happened to me before


So this half worked, after reinstalling gnome I was able to connect to wifi in gnome but not xfce (at first) so then I looked into removing the gmone after I connected and used pacman -R -u gnome instead of pacman -R -c gnome and that seemed to have worked, I don’t see what else broke it but it seemed reinstalling gnome then uninstalling it with -R -u fixed it. Any insight as to why getting rid of gnome breaks important system files like that?

From the pacman man page… (emphasis mine)

-c, --cascade
Remove all target packages, as well as all packages that depend on one or more target packages. This operation is recursive and must be used with care, since it can
remove many potentially needed packages.

Yeah, I guess this really was my own fault

@ben781 There are nicer ways to ask. See Questions regarding environments post by @Bryanpwo and I quote " when you’re stuck, there are simply no stupid questions"



Wish you a euphoric journey onboard Endeavour!



Funny thing is, to test status you must write NetworkManager, I hate this from day one on arch :smiley:

$ pacman -Q networkmanager                                                                                                                 [1]
networkmanager 1.26.2-1

 12:08:10  sgs@mx  ~/Downloads 
$ systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
     Active: active (running) since Sat 2020-08-22 10:58:38 CEST; 1h 9min ago
systemctl status networkmanager
Unit networkmanager.service could not be found.

yes this one gets me each time same for cups socket ( org.cups.cupsd.socket) but I think arch did some completion into new archiso :wink:

1 Like

You can also reinstall the new DE packages after remove the ones from old used DE, this will make sure to have a complete environment.


Because Xfce uses gnome packages and some of the gnome packages are better than xfce’s


System monitor , calculator , Disks utility ,

In your case the ‘c’ in pacman -Rc took the networkmanager with it . I did it with -Rsu though ; when removing Xfce to use KDE

Heh, I can’t help but see it running on two little orange legs. :joy:


Now I can’t see anything but them!


1 Like

Wouldn’t it be better if you could just ask what hardware do you have?

Could you please post the following …?

This is the way that we would like this forum to operate. Be nice and polite and respectful otherwise don’t bother to respond. I don’t think you would like to be treated in this way? Not all users think before they type. It is up to all of us to try to educate others on the protocol.

Thanks for your co-operation.


Or would you be willing as this page says :wink:

Hey anon, you’re consistently being a dick. Cut it out.