After update, ethernet doesn't work after every reboot

After update yesterday. My ethernet cannot connect anymore. It cannot access my Router’s config page but my router recognize that the device is connected.

I need to run sudo modprobe r8169 as suggested in one of the forum post.

After I run that, it worked but it won’t work anymore after reboot. So I have to run that command after every reboot.

What might be the issue and what is causing it? How should I resolve it? So that I won’t have to manually run the command every boot.

 inxi -nN
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: a8:a1:59:8b:3c:a9

Is the 8168 driver installed?

I don’t know how to check that.

You could use yay -Ss r8168
It will say installed if it is.

Oh it’s a package!! yes it’s installed.

Strange, inxi showed r8169 (note the last number!). Are you sure?
Please show the full output of command

pacman -Q r8168

OP modprobed 8169, uninstall 8168, 8169 will take over…