After nvidia installation system wont reboot

I have been trying to follow the wiki and the forum page but every time i follow the wiki the graphics card doesn’t pickup while when I install bumblebee from the dkms and i go to reboot it dose not reboot
What should i do
What i did until now was
Yay -S nvidia
Yay -S nvidia-utlis
Yay -S linux-headers
And after that flopped
Nvidia.dkms or something -b
And it wont reboot
Am i doing somthing wrong?
I have a gtx 1660 ti

hello do you have a laptop or not ,more can you make us one: inxi -F thank you

Yes i do have a laptop
Wdym make us one?

I believe he means: can you show here the output of a terminal command

inxi -F

if you use nvidia-installer script, no need to install nvidia drivers on your own the script will handle this completely.
But first make sure your system is an optimus hybrid system.
Also give the log from using nvidia-installer-dkms script to see if there was failing something…

So yes it has optimus support
And what you mean is that i just download the script from the nvidia installer and it will work fine?
Because when i did it it didnt reboot

Yes when i follow that i do everything shown Download bumblebee and it dose not reboot

which OS was before?

Did you run the installer in test mode?

nvidia-installer-dkms -b -t

Post the errors.

To install if no errors

sudo nvidia-installer-dkms -b

When i run it in test mode it says
Couldn’t find a driver suitable for your graphics card

Windows 10

secure boot activated or not

No i deactivated secure boot otherwise I couldn’t install Linux

yay -S nvidia-installer-db

Run

nvidia-installer-db

Then run the test and see if errors. If not install.

How should i run it?

Install this.
yay -S nvidia-installer-db

Then run
nvidia-installer-db

Then run test mode
nvidia-installer-dkms -b -t

If no errors install
sudo nvidia-installer-dkms -b

How do i run it??
Is there a command
I know how on Ubuntu based but not on arch

Put in the terminal exactly what i have typed. I will mark them bold. Give me a second.
Edit: Make sure you type them in exact. Do not copy and paste.

When I type nvidia-installer-db it says
Bash: nvidia-installer-db: command not found
After i installed it