After installing Endeavouros BSPWM

Login keeps returning to the same login screen.
Tried uncommenting picom in .config/bspwmrc/bspwm
System is * i7 4th generation
* xeon 3rd/4th generation graphics
* 8 gig ram

hey welcome here :enos:

latest picom seems to get started automatically as it has an /etc/xdg/autostart/ in the package now…
so if may dex is installed and used it will start picom also you do not have it in the BSPWM startup scripts

Thank you for responding so quick. I am to some extent a noobie. Could you explain in more detail please. Have been using Endevouros for about a year now.

Thank You so much to joekamprad.
You really a very helpfull community

Problem is solved. Just commented out dex in the script ~/.config/bspwmrc/bspwm.

Once again thank you.



we should go forward to solve the picom issue so you will be able to use transparency if you want that…
you could start with some hardware and drivers info:
inxi -Fxxc0z | eos-sendlog

eod sendlog.odt (41.4 KB)

vsync = true;


vsync = false;

in the picom config could help…


cp /etc/xdg/picom.conf.example ~/.config/picom.conf
and edit ~/.config/picom.conf vsync to false…

1 Like

Sir it is working properly now.
Even welcome is popping up now.


1 Like