After installing, black screen on boot

Hi! I recently decided that I want to switch to Linux. I did some research and found EndeavourOS, so I decided to use this type of distro.

I created a bootable flash drive and installed
the OS on my PC. After pressing done, I rebooted it and the next thing you know - black screen.

Well, I did try to do some things, but I couldn’t find the solution.

I uploaded a video of the problem in this site:

I’m a newbie so please try explaining things not so difficult for me to understand…


PC specs:

CPU - AMD Ryzen 5 3600
GPU - Nvidia GTX 1660 ti
RAM - DDR4 16GB 2400MHz
MOBO - Asus TUF Gaming B450M-Plus II
SSD (system) - Kingston 500 GB
HDD - SeaGate 1 TB

youn are able to swith to another TTY by pressing Ctrl+Alt+F4 ?

And welcome here i am sure we made you join the purple side :enos:

Sadly, no…

After pressing those buttons - nothing happens, still a black screen.

Sorry to see you strugeling… installer is good but not 100% perfect.
Without the installer logs it is hard to tell what went wrong, but i bet it does not boot at all and show the only a black screen.
In case there is no other OS insztalled this indicates it fails to install the bootloader. There is a known BUG where this happens also installer confirmed install is finished…
By any chance system is set to legacy Bios CSM mode or is older Device like 10y old? in this cases it will be the BUG we see on legacy install mode where users manually partition the drive and it fails to install the bootloader.

If Device is modern efi capable make sur eto disable legacy support mode in the Firmware/Bios and start over … Once in the LiveSession of the installer check if you booted in efi mode by opening a terminal and run this command:
It will show something like not supported if system is booted in legacy and some boot entries list if it is efi boot.

This would be shown if boot is legacy and not efi:
Screenshot 2024-06-20 115951

Thanks, it worked!

I disabled the CSM and it booted!

Well, it did show a black screen with a cursor, but I just reinstalled it and now it works very well…

Now I am a part of EndeavourOS :slight_smile:

1 Like

Marking a post as solution is to honor the user helping you first and second to close the thread automatically later. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.