After fresh install, no internet connections

Hi i just instlled EnOS and dont have interenet acces via wiifi - it was not accessible during instaltion so I used cable connection for installing

I have KDE desktop and down right on networks I can see No available connections.

here are some of the details

[nirvikalpa@nirvikalpa-arch ~]$ inxi -Fxxxxz
  Kernel: 6.1.60-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11
    wm: kwin_x11 vt: 7 dm: 1: LightDM v: 1.32.0 2: SDDM note: stopped
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 20F5S2XK00 v: ThinkPad X260
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20F5S2XK00 v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R02ET74W (1.47 )
    date: 09/15/2020
  ID-1: BAT1 charge: 34.1 Wh (96.1%) condition: 35.5/47.5 Wh (74.7%)
    power: 5.9 W volts: 12.1 min: 10.8 model: LGC 45N1735 type: Li-ion
    serial: <filter> status: discharging
  Info: dual core model: Intel Core i5-6200U bits: 64 type: MT MCP
    smt: enabled arch: Skylake rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 700 high: 800 min/max: 400/2800 cores: 1: 800 2: 800
    3: 800 4: 400 bogomips: 19204
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915
    v: kernel arch: Gen-9 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1,
    HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Lite-On [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 bus-ID: 1-8:3 chip-ID: 04ca:7058 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x106c res: 1366x768 hz: 60 dpi: 126
    size: 276x155mm (10.87x6.1") diag: 317mm (12.5") modes: 1366x768
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris x11: drv: iris
    inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 520 (SKL GT2)
    device-ID: 8086:1916
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d70
    class-ID: 0403
  API: ALSA v: k6.1.60-1-lts status: kernel-api
  Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:1570 class-ID: 0200
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Broadcom BCM4356 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: N/A pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0
    chip-ID: 14e4:43ec class-ID: 0280
  Device-1: Broadcom [] driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 bus-ID: 1-7:2 chip-ID: 0a5c:640e class-ID: fe01 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 252.54 GiB used: 7.09 GiB (2.8%)
  ID-1: /dev/mmcblk0 vendor: SanDisk model: SD32G size: 28.97 GiB tech: SSD
    serial: <filter> scheme: MBR
  ID-2: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: J4.3 scheme: GPT
  ID-1: / size: 218.04 GiB used: 6.92 GiB (3.2%) fs: ext4 dev: /dev/sda2
  Alert: No swap data was found.
  System Temperatures: cpu: 38.0 C pch: 38.5 C mobo: N/A
  Fan Speeds (rpm): fan-1: 0
  Processes: 181 Uptime: 37m wakeups: 3 Memory: total: 8 GiB
  available: 7.63 GiB used: 2.17 GiB (28.4%) Init: systemd v: 254
  default: graphical Compilers: gcc: 13.2.1 Packages: pm: pacman pkgs: 1010
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30

Can anyone help me out to resolve it? I would appreciate it.

Thank you

Welcome to the forum! :smile:

Have you read this already?

Maybe you need to install the driver:

sudo pacman -Syu broadcom-wl-dkms

and if needed, kernel headers, e.g.:

sudo pacman -S --needed linux-headers

Then reboot and try.

ok, i tried but still no wifi. i also tried to install linux-firmware as it was recommeded in some other thread
listing devices with lspci -k shows it is recognized

04:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4356 802.11ac Wireless Network Adapter (rev 02)
Subsystem: Lenovo BCM4356 802.11ac Wireless Network Adapter
Kernel modules: brcmfmac

but when i run ip a i cant see it

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 50:7b:9d:eb:60:2a brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute enp0s31f6
       valid_lft 85838sec preferred_lft 85838sec
    inet6 fe80::afc1:f2d0:363a:4331/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

any ideas why is that?

Probably need to blacklist that kernel module:

well. it seems to be solved somehow miraculously… i needed to unload/load the kernel modules and somehow it started to work… we will see how long it will stay :slight_smile:
anyway. thanx for help

Great! Let’s see if blacklisting is needed… :wink:

hmm… interesting… after restart the wifis are again invisible…

basically everytime i restart it, i need to write
modeprobe brcmfmac to kind of reload it again… then it starts working - why is that?

in such case i would go investigate into the boot journal, but do not post it here in case you do not understand send me P.M. with the url this gave out or pastebin it encrypted or even self-destructing here:

to create the boot journal and save it: journalctl -b -0 > ~/bootjournal.log
to pastebin it an get url of it: journalctl -b -0 | eos-sendlog
use general pastebin:

I noticed your bios version is from Sept 15, 2020. There is an updated bios for April of this year.

You should always update to the latest bios prior to installing the Operating System.

ufff. ive never really updated bios. dont even kniw how to do it…

Do you have Windows 10 or 11 on your laptop still?

The Lenovo vantage application will do all the updates for you.

Otherwise you will have to follow the instructions on this page to create a usb boot drive to flash your bios:

OR you can look into whether you laptop is supported by fwupd:

1 Like

If you don’t have windows installed you can download an use hirens boot cd / usb to run the bios update for the Lenovo. That is how i update for my Lenovo.

Try creating a file /etc/modules-load.d/brcmfmac.conf and put just the name of the module in it: brcmfmac

Reboot and see if it works.

kernel: brcmfmac 0000:04:00.0: Direct firmware load for brcm/brcmfmac4356-pcie.LENOVO-20F5S2XK00.bin failed with error -2

NetworkManager[599]: <info> [1698776899.7324] rfkill3: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/ieee80211/phy0/rfkill3) (driver brcmfmac)

FYI, should be aware of some microcode issues:

uff. it doesnt seem very good

is this because of the old bios?

Could be an issue if it calls for an old firmware file that is replaced…

mmm… ok. in that case i really need to figure out how to update the BIOS because nothing else from the above helped