After EOS and KDE update - PCIe USB hub stopped working

Hi all, so I’m a bit lost unfortunately…

I’ve recently installed the new EOS and KDE update, and since then my PCIe USB-card seems to have stopped working.

Not sure how that happened, but I noticed the issue when I wanted to use my USB-microphone and it didn’t work. After some troubleshooting I unfortunately couldn’t even get it to show up with arecord -l, which only showed the motherboard audio stuff.

These are the devices I’m using:

If I plug in any other devices they also won’t work.

Anyone have any pointers for me?

Try a different kernel. If you are using linux-lts, try linux or vice-versa.

Same issue on LTS :frowning:

Drivers are really not my thing, so this may be completely unrelated or stupid.

But when I look at the USB controllers in the info center, they say which driver they are using. And while this Fresco FL1100 says it uses the xhci-pci kernel module, it doesn’t note that it’s using any driver.

Might that be an issue?

What does this show?

lsmod |grep xhci

xhci_pci               28672  0
xhci_pci_renesas       24576  1 xhci_pci

Maybe try the firmware package from the AUR.


Edit: Would need to reboot after installing.

Edit: I have the same outout on mine although i don’t have a USB 3.0 card since my system is newer and has usb 3.0, 3.1 and 3.2 ports.

[ricklinux@rick-ms7c37 ~]$ lsmod |grep xhci
xhci_pci               28672  0
xhci_pci_renesas       24576  1 xhci_pci
[ricklinux@rick-ms7c37 ~]$ 

Not sure if this will solve the issue or not but worth a try hopefully. I don’t have this AUR package installed either.

Tried it with that package now, doesn’t work on LTS or the newest release :frowning:
The card still doesn’t want to use a driver.

It’s super weird, since I didn’t knowingly change anything at all.

Oh yeah, and thanks for the quick replies! It’s much appreciated. :slight_smile:

Edit: Is there a way to force it to use a driver or something?

Well you can just remove the AUR package then.

I assume you are using a power supply cable to the card?

After some open heart surgery I can confirm that it has a power supply and the LED on the PCB is glowing as well.

dmesg | grep 03:00.0 gives this output specific to this device:

[    0.322828] pci 0000:03:00.0: [1b73:1100] type 00 class 0x0c0330
[    0.322856] pci 0000:03:00.0: reg 0x10: [mem 0xdf400000-0xdf40ffff 64bit]
[    0.322875] pci 0000:03:00.0: reg 0x18: [mem 0xdf411000-0xdf411fff 64bit]
[    0.322893] pci 0000:03:00.0: reg 0x20: [mem 0xdf410000-0xdf410fff 64bit]
[    0.322958] pci 0000:03:00.0: supports D1
[    0.322959] pci 0000:03:00.0: PME# supported from D0 D1 D3hot
[    1.546887] xhci_hcd 0000:03:00.0: xHCI Host Controller
[    1.546891] xhci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 5
[   21.287450] xhci_hcd 0000:03:00.0: can't setup: -110
[   21.287828] xhci_hcd 0000:03:00.0: USB bus 5 deregistered
[   21.287911] xhci_hcd 0000:03:00.0: init 0000:03:00.0 fail, -110
[   21.288285] xhci_hcd: probe of 0000:03:00.0 failed with error -110

From what I’ve seen online this mostly seems to be power related, but now I’m even more confused.

Where do you have the power supply line connected from the power source? I’m not sure what the type plug is going into the usb card but would be best if you are coming from a molex plug off the power supply.

Edit: Does the Pci-e slot you have it plugged into use all available lanes?

It’s molex presumably coming directly from the PSU. Not sure anymore, but I can’t check without disassembling most of it now. Also no issues in the 5 1/2 years I had it in the PC now.

It’s using all lanes I think - at least the plug matches the length of the socket.

Unless something coincidentally broke in my pc during the update I honestly can’t believe that I’m getting hardware issues now.

Are you on the latest kernel? 6.7.9-arch1-1

Edit: Besides trying the lts kernel did you try downgrading the kernel and headers to the previous?

Just tried downgrading, still nothing. Which is super weird…
Guess I’m going to do some spring cleaning of the PC tomorrow. Maybe something will become obvious then.

I do think I recall stuff working after a reboot directly after the update, so maybe something actually broke physically during the night afterwards.

In any case, I’ll call it a night for now. Thanks for all the help.
I’m still open for any suggestions what I might check.

Thank you very much for your quick responses and effort @ricklinux and @dalto! It was in fact a hardware issue for whatever reason.

As “last ditch least amount of effort try for a fix”, I removed the power plug and made sure the pc was completely current free. Booted up the most recent linux release and it works again.

I presume that while the card had power and was working, it might have been in some kind of deadlock or invalid state and would not reset on a normal reboot.

Meme for clarity:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.