"Add software" shows No Package Found

hello Everyone,

when i try to add software using the “add software” i only get the “no package Found” ereror message.
i am not sure if i am missing something or something is broken with my system.

i have installed using software with the cli so far but it would be nice to get this working.


A temporary workaround that seems to work is to downgrade archlinux-appstream-data.

sorry, i am not knowladgable about this sort of thing, would you mind explaining why?

He probably means the package he mentioned is causing the problem after update.
Downgrading a package means getting an older version of it back. To do so, you can give this command in a terminal:

sudo downgrade "name-of-the-package"

But before that I’d suggest fully updating your system with terminal command

sudo pacman -Syu

Then reboot to see if a simple update helps. If not, then try downgrading.

thank you for explaining.
i am familiar with some of the concepts like downgrading.
i tried a full system upgrade, but this did not seem to help.

is the issue i am having having a known issue where downgrading is a common solution?

also, do i need to worry about any other effects downgrading “archlinux-appstream-data” could have?

Downgrading can only be a temporary workaround. Downgrading can create problems with (other) apps, especially when downgrading core packages.

Downgrade offers to ignore package updates using setting IgnorePkg in file /etc/pacman.conf. When there is an update to the ignored package, pacman will show it is ignoring it. When the problem gets fixed, you can remove the ignore setting and let pacman update it again.

Edit: it is recommended not to use pamac for installing, updating, or removing packages. Better use pacman (or yay) for those operations.
Pamac is useful for browsing packages.

1 Like

It is just a database used in some AppStream-based software centers.


It is not a pamac issue per se. Have a look at this Gitlab report. It is an old one but it may give you some explanation:

1 Like

thank you very much for the explanation.
downgrading also solved the issue :slight_smile: