Add myself to group

I am using an app called efax-gtk and it needs to access my modem. I am getting permission errors

efax-0.9a: 12:57:53 Error: can't open serial port /dev/ttyACM0: Permission denied

And the dev tells me:

“find out what group it belongs to with ls -l /dev/ttyACM0 and add yourself to the group.”

How to do that? I see my user name, “shmuel”, in the output, but I still get the error.

ls -l /dev/ttyACM0
crw------- 1 uucp shmuel 166, 0 Aug 11 12:52 /dev/ttyACM0

Please refer to:



I added shmuel to uucp

sudo gpasswd -a shmuel uucp
[sudo] password for shmuel: 
Adding user shmuel to group uucp

but I still get the error.
Does it require reboot?
(I’m in the middle of video editing…)

nice … a modem? i would like to be able to use such device fot fax… but ISP here do not provide real telefon lines :frowning:

1 Like

From the wiki page you just read:

1 Like

post the output:


Reboot, but log out log in should do guess.

edit: @jonathon beat me to it :wink:

1 Like

Good, so I added myself to the group, but by default the group has no access rights to this file. I can change the rights manually to read and write, but it doesn’t survive a reboot.

How do you do that?

What are the default permissions?

The default permissions are as in screenshot. I change them by opening the directory in root Thunar, right-click, then permissions tab.

Hmm. You might need to tweak the udev rule for the modem so it adds MODE="0660" for group read-write permissions,


Wouldn’t just sudo chmod ug=rw /dev/ttyACM0 do it?

Perhaps that is what you said?

1 Like

It would fix it for the current session, but will reset when you reboot. So kind of. :grin:

In contrast, a udev rule will trigger whenever the hardware is connected, so will “fix” it forever.

1 Like

I see. I shall be studying the link you posted. Thanks!

1 Like

Thanks to all for the wise comments. I am finding that Efax-gtk is buggy in many ways, so I am not even going to put more effort into it.

I did finally get Hylafax to work, after joining the appropriate group at SourceForge, and the dev sorted out my issues. So I don’t really need efax.