`acpi` command gets instantly killed by OS

Hi there,

I was troubleshooting why an i3blocks battery script wasn’t showing me anything and going down the rabbit hole I found out that my acpi commands is getting killed instantly by the OS.

  • I’m running on a laptop: Lenovo ideapad 730S-13IWL
  • /proc/acpi does not show any battery (I think this is discouraged now, though?). However, tlp-stat --battery returns coherent data (charge, capacity, BAT0 label for battery, etc.)

Output of acpi:

❯ acpi
[1]    7902 killed     acpi
❯ sudo acpi
[1]    12256 killed     sudo acpi

Output of TLP:

--- TLP 1.5.0 --------------------------------------------

+++ Battery Care
Plugin: asus
Supported features: none available
Driver usage:
* natacpi (asus_wmi) = inactive (laptop not supported)

+++ Battery Status: BAT0
/sys/class/power_supply/BAT0/manufacturer                   = CPT-COS
/sys/class/power_supply/BAT0/model_name                     = L17C4PE1
/sys/class/power_supply/BAT0/cycle_count                    =      0 (or not supported)
/sys/class/power_supply/BAT0/energy_full_design             =  42010 [mWh]
/sys/class/power_supply/BAT0/energy_full                    =  30690 [mWh]
/sys/class/power_supply/BAT0/energy_now                     =  20690 [mWh]
/sys/class/power_supply/BAT0/power_now                      =  23973 [mW]
/sys/class/power_supply/BAT0/status                         = Charging

Charge                                                      =   67.4 [%]
Capacity                                                    =   73.1 [%]

What I tried so far:

  • acpi_osi=Linux in grub

This issue seems nonexistent for other users, so there hasn’t been a lot of solutions tried.

Where does that command come from?

What does this show?
acpi -b

1 Like

community repo, according to pacman.

Command is located in /usr/bin/acpi on my PC.

Thanks for the quick response!

Sorry for the deleted post, I didn’t want to spread my ignorant response.

Here is the output:

# acpi -b
Segmentation fault

This output is bizarre to me as earlier today that same command gave no output and just got killed, much like the regular acpi command.

The output of acpi is now also a segfault. Weird…

The problem seems resolved for now. I checked the recently updated packages and acpi was not part of the list so I do not know what happened.

I would say it would have had to be installed then. :thinking:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.