About getting package list when installing in China

I now face a problem regarding installing the system. I wanna install endearvour os with i3wm, but the problem is that I can only install i3wm when selecting online install. Can’t get package list; It says the internet connection is down. I know how to bypass the GFW, however that’s usually what I do when having installed the os. I just wanna install i3wm out of the box, so I don’t need to do other tedious work. Is there a way I can do it when installing Endearvour? (I don’t have a VPN). Thanks.

The official Arch mirrorlist contains several China mirrors - you shouldn’t need an outside mirror.

Before starting the installation

  • Edit the mirrorlist on the ISO and move the China mirrors to the top of the list.
  • Remove the # in front of the line(s)
  • Save the file and run sudo pacman -Syy
  • Start the installer
## China
#Server = http://mirrors.163.com/archlinux/$repo/os/$arch
#Server = http://mirrors.bfsu.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.bfsu.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.cqu.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.cqu.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.dgut.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.dgut.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirror.lzu.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.neusoft.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.neusoft.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.nju.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.nju.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirror.redrock.team/archlinux/$repo/os/$arch
#Server = https://mirror.redrock.team/archlinux/$repo/os/$arch
#Server = https://mirrors.sjtug.sjtu.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.tuna.tsinghua.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.tuna.tsinghua.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.ustc.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.ustc.edu.cn/archlinux/$repo/os/$arch
#Server = https://mirrors.xjtu.edu.cn/archlinux/$repo/os/$arch
#Server = http://mirrors.zju.edu.cn/archlinux/$repo/os/$arch
2 Likes

It is also possible to refresh your mirrors from the welcome app that pops up when you boot upp your EOS usb. Then choose China and save the list.

1 Like

Thanks for your reply. didn’t expect to receive this fast. I did click the update mirror button, and I chose shanghai(china) timezone, although I set English as my system language. Nothing changed. Still the same problem.

1 Like

Thanks for your help. I’ll look it up. Never tried arch based system before. long time debain user. Wow, Endearvour community is really great.

3 Likes

I always update the welcome app after updating the mirrors and then start the installer. I don’t know if it might help in your case but online installing works fine when I do this.

I tried. Now the mirror seem to work, but it couldn’t get package list. maybe banned by GFW? Is there a way around this?

turns out it has nothing to do with the arch mirrors. I got china arch mirrors, but when installing , couldn’t get package list. It says the network is down. But I’m sure that It has Internet connection. maybe banned by GFW. Do you know a way around this, I just wanna install eos with i3 out of the box…

1 Like

Have you tried reflector?

May be I should change the title. arch mirrors work fine, but couldn’t get package list.

The only thing you would be missing is the endeavouros specifics which is only the user settings.

My guess is that your gfw does not allow access to github. Can you access this page?

Then you could work around it by cloning the repo and doing a manual install.

git clone https://github.com/endeavouros-team/i3-endeavouros.git

The file packages-repository.txt provides the packages - which can be installed by using stdin

sudo pacman -Syu - < packages-repository.txt

Yes, I can access this page without using a proxy. Then what’s wrong here?

I don’t know - if I remember correct the net installer is a work in progress - so in your case

  • do an offline install of xfce
  • clone the repo and follow the instructions in the README.md file

logout and at the lightdm login choose i3 and you are on

It is possible to install offline Xfce, and later install i3 packages and, if you want, remove Xfce packages. (Just noticed this was already suggested…)

But is your problem such that you can’t install EndeavourOS packages (which are not on Arch mirrors)?

If so, the best solution would be to have EndeavourOS mirrors also in China, which unfortunately we currently don’t have.

but packages is ok i dont know how you can reach the endeavouros mirror for the configuration, you can connect to github basicly?

I’ll just install i3wm manually. My problem is that I can connect to the github, and have arch mirror in china, but when installing, can’t get package list(says the internet connection is down). Thanks.

I can connect to github, no problem. Yet, can’t get package list. whatsoever, I’ll just install i3 manually.

1 Like

Welcome in the forum!