A problem with Guvcview (webcam app for recording)

Hi

I bought time ago a Logitech webcam, concretely the HD Pro C920.
The thing is that this app (guvcview) records very good video, but with NO AUDIO. I tried different configurations but videos have no sound at all. I proved PULSEAUDIO, PORTAUDIO with hw:2.0 settings, with different sample rates with mono and stereo channels, but i couldnt get anything good as for audio.

what can i do?

for me it coredumps on changing audio to pulseadio … but i am using pipewire here.
On Pulseaudio (default used in EndeavourOS) you need to set the input device to be used, with pavucontrol in configuration tab, and it must show up in input devices and acting:



Make sure only one input device is activated in config.

but i see the same it does not record sound in any way too here…

what gives you?
pactl list sources

Source #8
	State: RUNNING
	Name: alsa_input.usb-046d_HD_Pro_Webcam_C920_DC6E94DF-02.analog-stereo
	Description: HD Pro Webcam C920 Analog Stereo
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 32000Hz
	Channel Map: front-left,front-right
	Owner Module: 7
	Mute: no
	Volume: front-left: 65841 / 100% / 0.12 dB,   front-right: 65841 / 100% / 0.12 dB
	        balance 0.00
	Base Volume: 9619 /  15% / -50.00 dB
	Monitor of Sink: n/a
	Latency: 638 usec, configured 40000 usec
	Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "2"
		alsa.card_name = "HD Pro Webcam C920"
		alsa.long_card_name = "HD Pro Webcam C920 at usb-0000:04:00.0-2, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:04:00.0-usb-0:2:1.2"
		sysfs.path = "/devices/pci0000:00/0000:00:1c.4/0000:04:00.0/usb3/3-2/3-2:1.2/sound/card2"
		udev.id = "usb-046d_HD_Pro_Webcam_C920_DC6E94DF-02"
		device.bus = "usb"
		device.vendor.id = "046d"
		device.vendor.name = "Logitech, Inc."
		device.product.id = "082d"
		device.product.name = "HD Pro Webcam C920"
		device.serial = "046d_HD_Pro_Webcam_C920_DC6E94DF"
		device.form_factor = "webcam"
		device.string = "front:2"
		device.buffering.buffer_size = "256000"
		device.buffering.fragment_size = "128000"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "HD Pro Webcam C920 Analog Stereo"
		module-udev-detect.discovered = "1"
		device.icon_name = "camera-web-usb"
	Ports:
		analog-input-mic: Microphone (type: Mic, priority: 8700, availability unknown)
	Active Port: analog-input-mic
	Formats:
		pcm

Source #15
	State: RUNNING
	Name: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
	Description: Monitor of Built-in Audio Analog Stereo
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 8
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor of Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
	Latency: 0 usec, configured 40000 usec
	Flags: DECIBEL_VOLUME LATENCY 
	Properties:
		device.description = "Monitor of Built-in Audio Analog Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xdf240000 irq 137"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a2f0"
		device.product.name = "200 Series PCH HD Audio"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Formats:
		pcm