"A Media driver your computer needs is missing" Error when trying to re-install windows from Arch Linux

I’ve installed EndeavourOS and been having a lot of issues with it, constant freezing, screen flickering and other weird stuff, I’m trying to go back to Windows now, however each time I try to boot up the installer I’m running into an error where it can’t seem to recognize/find my SSD device to install windows onto, I thought maybe I didn’t burn/mount the ISO properly into the USB stick but I tried multiple times with multiple tools, I tried so far: Ventoy using Partition Manager to create a new table on the USB stick for NTFS tried FAT32 re-copied the files

nothing seemed to work, each time it would end up telling me I don’t have a drive to install windows on, am I missing something?

I’m using a Corsair MP600 GS 2TB SSD

viewing it with the partition manager it shows nvme0n1p2 as ext4

could it be because my drive has been changed to ext4 windows installer can’t see it? what can I do?

any help appreciated.

It has nothing to do with what you did when installing EOS, or any other OS. If it is an ASUS laptop for example, you need to install some drivers first (usually you copy these drivers to the install USB stick). It’s like back in the old days, they just need a driver to recognize the drive.

Just google whatever your error output is and add PC brand and “Windows 11 [or whatever version you need] install” in the search query.

Also the errors you ran into with EOS might have a simple fix. You could take advantage of the great community here and try to solve those flickering/freezing issues and get a stable system, if you’re still interested in running linux.

Boot up the live installer for EOS and start gparted go to Devices and choose make partition table > gpt. Leave it unallocated. Don’t format it. Reboot into your win installer. Backup anything in EOS installation that you want to save before doing this.

Just so I got this right, you’re saying ill need 2 bootable flash drives, one with EOS and one with Win 11, I boot up EOS as if I’m trying to re-install EOS, from there ill be able to partition my drive anew (since I can’t do it from the desktop as the drive is mounted and used and cannot be touched) and then ill be able to switch to my Win 11 flash drive and boot up Win 11 which then will be able to see the new partitioned drive with all the unallocated space?

I assume I should be able to do this without needing a 2nd stick by using Ventoy and slapping both ISO files of EOS and Win 11 on it?

Yes. I dont know Ventoy but yes if that’s possible with Ventoy than do that. If not use 2 usb’s 1 for EOS and 1 for win11

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.