A bug about the multi-screen setting

Hi, guys! The following might be explained as a bug. :innocent:

The system is one that I installed today using the latest offline version. It uses lightdm.

In the picture, I choose the laptop as the main display, while actually it is the upper screen which is set as main screen.

This is the my setting

while this is the true display effects

but while I exchange their locations in the setting. It seems as if everything is OK!


Update:
I tried manjaro xcfe and found it is the same problem. So it is quite obvious that it is the xcfe4’s problem.

Could you try installing arandr? To see what it shows?

And indeed welcome here :enos:


the one that is labeled as hdml is my larger screen and the edp one is my laptop screen, which is set as primary screen, but the practical effects are totally wrong.

it looks like that the setting is perfectly right, so it might be possible that the x.org system or the xcfe4’s code has some potential logical error.

Moreover, I tested with Ubuntu, which is equipped with Gnome, it turns out that works perfectly right.

Could be Ubuntu has a fix for mal working hardware … or it is a Bug on Xorg. … also possible gnome on Ubuntu uses Wayland.

Yeah, there is one more thing that convinces me that it is a bug; the problem occurs only when I place the HDMI screen in the upside or the left.

Moreover, this problem occurs in all the xcfe4 system including Manjaro. I also tried it with the Mint which is driven by Cinnamon and it turns out that everything is OK.

It is so symmetric(only up and left would meet with some errors) that I believes that there might be some important code which was skipped by some "goto"s. (the Apple’s IOS event)

I don’t know if this arose from my hardware’s not corresponding with xcfe4. But if this is a technical issue, please transfer this message to the xcfe4’s working team. Thanks!

And I had found a issue report that might arose from the same problem as I am, which is posted on the gitlab of xcfe.
Window cycling popup does not show at all when two monitors configured to mirror output and external monitor is primary. (#599) · Issues · Xfce / xfwm4 · GitLab

EndeavourOS is not developing xfce4 :wink:
We do o ly using packages from archlinux repository.
So bugs with packages themselves or xfce4 upstream should be reported at the sources.