A boot mystery, or several. What?! Secure boot OK out of box

Over the last 6 months I switched 3 machines to EndeavourOS. So far so good… until this Dell Laptop.

The laptop had Ubuntu on it. I just moved the root filesystem with ubuntu to a subfolder, and installed EOS into the same partition. The first time I chose “online update” and grub. The online update failed. So I did the offline one. Then grub failed. So then I did the offline one with systemd.

It booted perfectly! With Secure Boot on! I am not sure which boot option it used, but I suspect it was the systemd one.

Then came the first update. It complained about not being able to overwrite BOOTX64.EFI. (So I renamed it. It wrote a BOOTX64.EFI that’s almost 10x bigger. But only after I figured out that the command to run is not the dracut rebuild command,. which I ran, but that I just needed to reinstall “linux” (the kernel package))

Reboot. Nope. It had the systemd boot and grub, and Ubuntu’s systemd and grub options. Nothing worked. The only error I could see was one about virtual console setup that failed. (Did I make the mistake of not choosing EN-US in the installer?! The one time I think… okay lets try the suggested default.) Sometimes it came to “Enter password for maintenance” - but I couldn’t type! Sometimes it would just have a lot more failures, starting with “Failed to start D-Bus System Message Bus”. But I could still boot with init=/bin/bash and look around…

Then I made the first real mistake. I turned off secure boot. I tried every iteration, similar failures. When I got to “Enter password for mainenance” I just couldn’t type.

Then I turned back on Secure boot. Now nothing worked anymore.

So I turned it back off, and tried Legacy boot. Nope no legacy boot options even got to a bootloader.

UEFI with Secure Boot Off again.

After going though several “Enter password for maintenance” with me not being able to type, I finally figured out that if I boot with Grub, and type in:

root=(hd0,1)  # my EFI partition
linux /b84d666250124276b26f1eabb362ceb8/6.8.7-arch1-1/linux root=/dev/sda2 rw
initrd /b84d666250124276b26f1eabb362ceb8/6.8.7-arch1-1/initrd

Then it would boot.

I couldn’t find a grub.cfg so I suppose its embedded in one of the other files. (Which one?)

Now it boots, still shows the “virtual console setup” error, but I get lightdm! (Hurray!)
But when I log into lightdm, the screen goes black, and keyboard dies. (Ctrl+alt+del doesn’t shut down or reboot) - Power button once (not forced) shuts it down, so it’s not completely non-responsive.

If I follow the same, and open a virtual console, manually run Xorg, xterm, mate-session, everything works.


  1. Why doesn’t any input works after grub or systemd boot, on some of the sessions?
  2. Why would lightdm login do that? Running things manually without lightdm, work?

(There are more but I have to go now… :-()

I think if you have clean partitions you won’t have an issue and also update the mirrors before starting the installer. Secure boot should be off.

I think this is relevant, too, except I don’t know what you mean. i.e. a subfolder on the partition you installed Endeavour in? Where is the subfolder exactly in relation to Endeavour and the partition it’s on?
Because if you didn’t really uninstall Ubu, and they are neighbors, then I can see problems from miles away and I can’t say I’m surprised because parts of Ubu would still be running the show, as it were.
I think.

1 Like

Is it expected that this stream of consciousness post (littered with questionable descriptions of events and truly atypical installation method choices and including statements that simply SHOULD not be possible and describing the situation and actions taken with very non-standard language) be taken seriously, and even harder to imagine, that anyone could offer meaningful observations and guidance?


I don’t see how this can be an issue. It is essentially a clean ext4 filesystem, except that there’s a folder named ubuntu with files in it.

What I am much more curious about is:

  1. How did secure boot work and booted me into EndeavourOS at the first reboot? (Installation media was removed)
  2. Why don’t any keys work on some of those boots? (Not even Ctrl+Alt+Del)?
  3. Why would everything boot fine but it would fail from “Starting D-Bus” and then NetworkManager and Display Manager…? On these boots, the only thing that work is “Ctrl+Alt+Del”.
  4. And then, when I get to the display manager, why would it kill the display soon as I log in? Forcing me to reboot, and just shut down the display manager, and run X manually? (As I am now!)

I am pretty sure everything would’ve kept working if I didn’t update it… but it’s fully updated now. I guess that points to the systemd boot update breaking it. Which package would’ve been responsible? And where does it - and grub, which I installed too, after getting into a window manager, but it just added an EFI boot menu item called “arch” that doesn’t have a grub.cfg.

Obviously the original “grub” install that “failed” - didn’t fail, it did install a grub. It still boots with a theme and everything, its the one I used to get to a working desktop. But I can’t find its grub.cfg… is it embedded?

I just realized that I don’t really understand things as well as I thought… It’s not like there’s a special keyboard driver needed, or that the BIOS can lock out …what I presume is a PS2 keyboard? (Is that how Laptop keyboards work… I guess not! I wonder if they ever did.

Just that I really have a disproportional urge to understand what is causing each of the above… I mean, no keyboard input?! What could possibly cause that?

And then what does D-bus, networkmanager, and LightDM have in comon that just they would fail?

Why does everything (almost) work if I choose the kernel, initrd manually, and run Xorg and lightdm-session manually?

(I took photos of the screens, and based my comments off what I read, pretty sure I didn’t omit anything crucial, but it’s possible.)

Anyways I’m busy working my way through each of the above, and the related packages now, to find the answers. But if anything springs to mind, do tell! I will share what I find here… in case anybody is interested.

Maybe you can appreciate the fact that I was “offline and unable to do anything” while struggling with this, as it happened while I was on the road with a new laptop… and no internet.

Sorry if my language is “non-standard”. What specifically “should not be possible”? Using a pre-formatted partition? I think the installer handles it perfectly, and I have not had issues doing this with Ubuntu, ever. The only questionable thing in the Linux world IMHO is Ubuntu trying to force everyone to abandon spinning disks and even SSDs, and move to nvme’s with their snap disaster. Which they’re not even aware of because they all develop on supercomputers that almost nobody else in the Linux world can afford.

can you report

inxi -Fza
sudo lsblk -fs
sudo parted -l 
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v