5g Wifi Not Showing

I have 100 Mbps broadband connection(dual band). But the wifi adapter is not showing 5g connection. Not sure whether I have to use different driver. Please help.
Below is the results of “inxi -nza” commnd
image

You could start trouble-shooting with the nmcli-command:
https://cmdref.net/os/linux/command/nmcli.html

In addition, the ip-command may be useful:
https://www.cyberciti.biz/faq/linux-ip-command-examples-usage-syntax/#2

1 Like

There are two drivers in the AUR:
https://aur.archlinux.org/packages?O=0&SeB=nd&K=8188fu&outdated=&SB=p&SO=d&PP=50&submit=Go

Hi @ivanhoe , Thanks for the reply.
I am not sure what exactly to check using these commands. Below are results of “nmcli d” and “nmcli d show wlan0”

image

Also i tried installing both the drivers and i tried changing the band to 5GHz, still same issue.

image

Kindly help.

Check your Router settings, bc if you want to connect with WPA2 to your AP, you need to set both devices to WPA2 or WPA3 only. This could be an issue.

What happens if you leave the band on Automatic? Also, in your Router you can probably disable either one, 2.4 or 5 Ghz.

Its WPA2 only. If I leave the band on Automatic, still the 5f Network is not showing.

Well, if you leave NetworkManager and your router both on automatic - how can you know it is not showing?

If you enter this in terminal, it will show what is going on, and what not (after putting router AND computer on the same settings!) -

sudo iwlist wlan0 scan | grep Frequency | sort | uniq -c | sort -n

I ran your above command
sudo iwlist wlan0 scan | grep Frequency | sort | uniq -c | sort -n

Below are the results.
image

And what are your router-settings, and pc-settings at this time?

Looks like the router is only sending signals on 2.4Ghz in the picture.

No… The issue is that 5Ghz signal is not receiving in this laptop. But in my mobile and other laptop 5g Connection is showing.

Please find the below available networks showing in this laptop and in my mobile.
image
image

So my router is sending both signals, but in this laptop it is not receiving the 5Ghz signal.

1 Like

Edit (deleted duplicate info):
If all drivers fail, you could try installing an lts kernel:
yay -S linux-lts linux-lts-headers

There is mention on the net, that rtl8188fu-driver only is supported by Linux kernel <= 5.18.

I have executed the above command “yay -S linux-lts linux-lts-headers” and it reinstalled those.
After that i have installed this driver “8188fu-kelebek333-dkms-git” from AUR packages. Still same issue, 5g Network is not showing in the available networks.

Can you show the output of:
sudo cat /etc/NetworkManager/NetworkManager.conf please?

And this one, too:
sudo cat /etc/modprobe.d/rtl8188fu.conf

Please find the below results:
image

You could try adding this to the options-line in the rtl8188fu.conf file:

rtl8188fu rtw_ips_mode=0

And then reload the module driver:
sudo modprobe -rv rtl8188fu && sudo modprobe -v rtl8188fu

See if it works. I am not sure, but it has helped someone on the net.

Other than that, I really have no more ideas. Sorry…

Tried the above steps.
Still the 5g network is not showing.

@Vicky
I would try setting a different channel in your router settings.

Edit: Check iw list and see if any frequencies are disabled.

Hi @ricklinux ,

Ran this command “iw list”. Please find the below result:

[vicky@vicky-home ~]$ iw list
Wiphy phy0
wiphy index: 0
max # scan SSIDs: 9
max scan IEs length: 2304 bytes
max # sched scan SSIDs: 0
max # match sets: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Supported Ciphers:
* WEP40 (00-0f-ac:1)
* WEP104 (00-0f-ac:5)
* TKIP (00-0f-ac:2)
* CCMP-128 (00-0f-ac:4)
Available Antennas: TX 0 RX 0
Supported interface modes:
* IBSS
* managed
* AP
* P2P-client
* P2P-GO
Band 1:
Capabilities: 0x1962
HT20/HT40
Static SM Power Save
RX HT20 SGI
RX HT40 SGI
RX STBC 1-stream
Max AMSDU length: 7935 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 16 usec (0x07)
HT Max RX data rate: 150 Mbps
HT TX/RX MCS rate indexes supported: 0-7
Bitrates (non-HT):
* 1.0 Mbps
* 2.0 Mbps
* 5.5 Mbps
* 11.0 Mbps
* 6.0 Mbps
* 9.0 Mbps
* 12.0 Mbps
* 18.0 Mbps
* 24.0 Mbps
* 36.0 Mbps
* 48.0 Mbps
* 54.0 Mbps
Frequencies:
* 2412 MHz [1] (20.0 dBm)
* 2417 MHz [2] (20.0 dBm)
* 2422 MHz [3] (20.0 dBm)
* 2427 MHz [4] (20.0 dBm)
* 2432 MHz [5] (20.0 dBm)
* 2437 MHz [6] (20.0 dBm)
* 2442 MHz [7] (20.0 dBm)
* 2447 MHz [8] (20.0 dBm)
* 2452 MHz [9] (20.0 dBm)
* 2457 MHz [10] (20.0 dBm)
* 2462 MHz [11] (20.0 dBm)
* 2467 MHz [12] (20.0 dBm) (no IR)
* 2472 MHz [13] (20.0 dBm) (no IR)
* 2484 MHz [14] (disabled)
Supported commands:
* new_interface
* set_interface
* new_key
* start_ap
* new_station
* set_bss
* join_ibss
* set_pmksa
* del_pmksa
* flush_pmksa
* remain_on_channel
* frame
* set_channel
* connect
* disconnect
WoWLAN support:
* wake up on anything (device continues operating normally)
software interface modes (can always be added):
interface combinations are not supported
Device supports scan flush.
max # scan plans: 1
max scan plan interval: -1
max scan plan iterations: 0
Supported TX frame types:
* IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
Supported RX frame types:
* IBSS: 0xd0
* managed: 0x40 0xd0
* AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* P2P-client: 0x40 0xd0
* P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
Supported extended features:
[vicky@vicky-home ~]$

Are you sure this adapter supports 5 Ghz?

Edit: The other laptop you show is connecting to 5 Ghz so obviously it has an adapter capable of 5Ghz band. This doesn’t mean the RTL8188FTV does?

RTL8188FTV

802.11bgn USB 2.0 Network Interface Controller

General Description

The Realtek RTL8188FTV-VB-CG is an 802.11b/g/n 2.4G single-chip that integrates Wireless LAN (WLAN) and a network USB interface (USB 1.0/1.1/2.0 compatible) controller. It combines a WLAN MAC, a 1T1R capable WLAN baseband, and WLAN RF in a single chip. The RTL8188FTV-VB-CG provides a complete solution for a high-throughput performance and low power consumption integrated wireless LAN device. This product is designed for TV, Set-Top box/Over-The-Top box, IP Camera, etc. Wi-Fi applications.

Features

  • 24-pin QFN 4x4mm
  • Supports 802.11 b/g/n
  • Integrated PA/LNA/TRSW
  • Embedded Balun
  • Supports Wake on Wireless LAN
  • Supports Antenna Diversity

Edit: From the Realtek site it shows it’s only 2.4 Ghz

2 Likes

I bought this adapter today and in the box it says “500Mbps mini wireless USB Adapter” Terabyte brand :frowning: .

Could you please suggest a good wifi adapter then.