4K Display Stuck at 30hz

Edit: Please don’t respond to this one anymore. I appreciate everyone’s help in trying to get this issue resolved, but I don’t see it getting better. I’m gonna try a couple more distros and try to get 4k 60 working, and if I keep getting the same issue I’m just gonna go back to windows.

Hey y’all
I’m running endeavoros and I’ve been trying to get my displays working at the proper refresh rate and it’s not been working. Here is the guide I’ve been using
https://wiki.archlinux.org/title/xrandr
I input: cvt 3840 2160 60
and it outputs:

3840x2160 59.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 MHz

Then I input xrandr --newmode “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
and get no output
Then I input
xrandr --addmode DP-2 3840x2160_60.00
and get this as an output
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 45
Current serial number in output stream: 46
I am trying to get my 4k 60 hz monitors to run at their proper speed, they are stuck at 4k 30 hz as of now
They are both connected using dp 1.4 connections and my gpu (rtx 2070) supports it. the current drivers are installed as well

i am not sure of why your error shows up, but I don’t see a command to ‘activate’. Here’s a working script to up my laptop to 1920x1080 from 1366x768.

Script
#!/bin/bash
xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode LVDS-1 "1920x1080_60.00"
xrandr --output LVDS-1 --mode "1920x1080_60.00"

I did the same thing as before, adding the output line you suggested, and now I get this error. xrandr: cannot find mode 3840x2160_60.00

This implies some form of bandwidth limitation.

What happens if you connect a single display?

What sort of cables are you using, and in what arrangement?

2 Likes

They are both connected using display port 1.4, and worked fine at 60hz when I was on windows

It couldn’t be so simple as missing the " characters? Could it? Are we sure of the DP-2 designation? Beyond that, you’re out of my league - the days that I had to specify all that WITHOUT xrandr to get an ATI card to work for Motif are a long way in the past!..

Sorry - I realised I made the mistake of asking three questions in the same post, then expecting you to answer all of them in the same reply! Silly me!

So, I’ll ask just one question again:

I get the same issue when only one display is present, kinda glossed over that since I know it’s not a bandwidth issue

And the final question,

That is - is each display connected with its own cable, or are you daisy-chaining the displays, … ?

Monitor 1 is connected to DP-0, and Monitor 2 is connected to DP-2, I don’t believe my monitors support daisy chaining

Which desktop environment are you using?

Welcome to purple :enos: side of Linux.

If possible run the below command and post the output link here.

inxi -Fxxc0z --no-host | eos-sendlog

It’ll give everyone here a much better understanding of your system and will make it easier to answer as well.

https://clbin.com/YIlXz
Here is the link

You can check the added mode ( “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237) to see if it’s correct by using gtf 3840 2160 60. If your monitor passes it should show something like below.

# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

Above is mine just using it as an example.

Also, I think there is an issue with your add command. I think you need double quotes. Try changing this xrandr --addmode DP-2 3840x2160_60.00 to this xrandr --addmode DP-2 "3840x2160_60.00".

So I put it in the command, this time using the refresh rate of 59.97 because that is what windows always reported, so I figured I might as well try to see if I get something different

# gtf 3840 2160 59.97
Modeline "3840x2160_59.97"  711.98  3840 4152 4576 5312  2160 2161 2164 2235  -HSync +Vsync
# xrandr --newmode "3840x2160_59.97"  711.98  3840 4152 4576 5312  2160 2161 2164 2235  -HSync +Vsync
# xrandr --addmode DP-2 "3840x2160_59.97"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  45
  Current serial number in output stream:  46
# xrandr --output DP-2 --mode "3840x2160_59.97"
xrandr: cannot find mode 3840x2160_59.97

So I put in the addmode command using the output from gtf, and I get the same issue telling me it’s a bad match. also for giggles I put in the output command and it tells me it can’t find it

What do you have in /etc/X11/xorg.conf (or any files under /etc/X11/xorg.conf.d/)?

After saving output and attempting to change a couple things in accordance with this guide: https://unix.stackexchange.com/questions/574071/set-undetected-resolution-with-xrand
my xorg.conf file looks like this

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 470.74

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUS ASUS VP28U"
    HorizSync       134.0 - 134.0
    VertRefresh     40.0 - 60.0
    Option         "DPMS"
    Modeline "3840x2160_60.00"  712.75  3840 4160 4576 5312  2160 2163 2168 2237 -hsync +vsync
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce RTX 2070"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DP-0: 3840x2160_60_0 +3840+0, DP-2: 3840x2160_60_0 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

    EndSubSection
EndSection

there is an xorg.conf.backup file that looks like this

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 470.74

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUS ASUS VP28U"
    HorizSync       134.0 - 134.0
    VertRefresh     40.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce RTX 2070"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DP-0: 3840x2160_30_0 +3840+0, DP-2: 3840x2160_30_0 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I am logged on as root I probably should say, and doing the changes from the guide (assuming I’m not a bonehead and missed something major) didn’t do anything

Move the xorg.conf file out of the way, log out and back in as your normal user, then use KDE’s display settings to set the output configuration.

Potentially you set 30hz as the only option at some point,

1 Like

So should I delete both copies of the xorg.conf files? They weren’t there before I went into NVIDIA settings and saved the config to a file