260 MB EFI partition

trying to install EOS Cassini on my SSD with Windows already installed
the EFI partition is just 260 MB and I can not resize it I suppose, since is the first partition.
are 260 MB enough?
or should I resize it in someway?

thanks :slight_smile:

You can resize it but it might require moving the other partitions unless you can make the partition adjacent to it slightly smaller.

It is enough for grub. For systemd-boot, it is probably too small.

That being said, if you choose the systemd-boot option and don’t enlarge the partition, it will just add a second EFI partition and copy your Windows files over to it so it should work fine.

1 Like

yes, I plan to use systemd-boot
the partition adjacent to the EFI one is the windows one, encrypted with bitlocker
what do you reccomend? :slight_smile:
probably I will install another distro too

or maybe is it easier to add e second EFI partition?

but how will boot then? should I choose the EFI partition at boot?

It is definitely easier because the installer will do it for you.

You shouldn’t need to. The installer will default to using the new one. systemd-boot will automatically give you the option to boot between Windows and EOS.

If you install any additional distros, just be sure to use the new ESP instead of the old one.

1 Like

solved :smiley:
I’ve followed this guide:

created a second bigger EFI partition just for Linux

if anyone will follow the video, be extremely extremely careful, you have to change boot partition flags
maybe will not work on every PC

1 Like


The installer does it for you automatically.

1 Like

I didn’t read your answer :slight_smile:
the installer let me choose which partition to resize to create space for the second EFI partition?

1 Like

It uses the space you tell the installer to use for EOS. In other words, if you use “replace partition”, it puts the new EFI partition at the beginning of that space. Same thing for “Install alongside”

1 Like

This so-called OS was a PITA for me to keep around. No other penguin does what it does into ESP, and also fails to show up on blue EFI boot menu on HP computers. Upset someone at Solus forums told me my computer was too old after telling them that the MATE ISO worked for me but the KDE one refused to boot. I had a payware music program (yes I know, rather old) I liked running through 32-bit Wine but one of their updates broke it to the point where I wanted to give up entirely on that OS.

I’m like the OP, the slow HDD of my computer has ESP which is only 260MB but I’ve been doing just fine without Solus and other odd children like that. If that thing about “systemd-boot” is true then I don’t want it for internal HDD. I tried and failed to install Arch and otherwise the only Arch-based thing I trust into that disk is Manjaro. I happened to find a 32GB space for it where it’s going to stay.

Without thinking much about it, I did create a 1GB ESP for the disk I’m booting EndeavourOS KDE from. But at least four months went by before I got ahold of “systemd-boot” and decided to change D.E.