144hz external display capped at 70?

title, I’m running an external display off displayport from my laptop running eos kde wayland, and the main monitor just wont run at 144hz, strangely, running glxgears on the external monitor gives me 71fps on said display. It shows up as selected in KDE Settings (even the monitor OSD says its on 144hz). changing refresh rates below 60 does seem to take effect though, almost like its capped. Ive already tried the most common said “fixes” for this such as modifying kwinrc entries (MaxFps=144). Maybe it has something to do with NVIDIA? I don’t really know.

Additionally, audio over DP doesn’t work either as it doesn’t appear in the KDE Settings menu.

Here’s my hardware info: https://clbin.com/EEZdO

What version is your display port cable. Maybe check that and try a better quality cable that is certified to meet the standards. Lots of cables are inferior. Also you have nvidia and amd graphics. It is running on amdgpu currently not nvidia.

i’m not sure of the version but audio over DP did work on windows with the very same cable. If its of any help “HDA Nvidia” shows up in “Inactive Cards” in plasma audio settings

Also i’m pretty sure the DP port is wired directly to the nvidia gpu on this very laptop model (omen15 2020), it would be the monitor display that is running on amdgpu.

It is my understanding that the integrated Radeon graphics drive the built in screen. The nvidia gpu drives all external ports. i.e. HDMI, DP, USB-C. Most laptops switch to the nvidia when connecting an external monitor. You should be able to get 144 Hz with the right cable and if the monitor supports it. Some laptops use the type-c display port output and it automatically switches to nvidia. I don’t know your hardware. The output shows it using amdgpu.

Are there any options in the UEFI Bios to switch to dedicated graphics?

Doe this command list the nvidia?

xrandr --listproviders

Have you tried setting it with xrandr? Set proper port and resolution and refresh rate.

Example: xrandr - - output DP-1 - - mode 1440x900 - - rate 59.90

The monitor and the cable do indeed support 144hz, there is no option in UEFI Bios to switch to dedicated graphics

Doesn’t seem to, this is what shows up:

Providers: number : 0

Also, since i’m using wayland (i installed the wayland plasma session in place of xorg since it was unusable with my second display and would stutter a lot), may i ask why xrandr?

It doesnt work, may i ask why xrandr when im on the plasma wayland session? Thanks a lot in advance

I guess xrandr doesn’t work on Wayland so that won’t be helpful. :unamused:

How about

kscreen-doctor -o
Output: 1 Najing CEC Panda FPD Technology CO. ltd eDP-1-unknown enabled connected  Panel Modes: 0:1920x1080@60*! 1:1920x1080@40 2:1680x1050@60 3:1280x1024@60 4:1440x900@60 5:1280x800@60 6:1280x720@60 7:1024x768@60 8:800x600@60 9:640x480@60 10:1600x900@2058702 11:1368x768@-1501773 Geometry: 0,0 1920x1080 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown 
Output: 2 BNQ BenQ EX2510/L1M00666019 enabled connected primary DisplayPort Modes: 0:1920x1080@60! 1:1920x1080@144* 2:1920x1080@120 3:1920x1080@100 4:1920x1080@60 5:1920x1080@50 6:1920x1080@30 7:1920x1080@25 8:1920x1080@24 9:1680x1050@60 10:1600x900@60 11:1280x1024@144 12:1280x1024@120 13:1280x1024@75 14:1280x1024@60 15:1280x800@60 16:1280x720@60 17:1280x720@60 18:1280x720@50 19:1024x768@144 20:1024x768@120 21:1024x768@75 22:1024x768@60 23:800x600@75 24:800x600@60 25:720x576@50 26:720x480@60 27:640x480@75 28:640x480@60 29:640x480@60 30:1368x768@-1501773 Geometry: 1920,0 1920x1080 Scale: 1 Rotation: 1 Overscan: 0 Vrr: incapable RgbRange: unknown primary

Although it shows 144hz is selected it isn’t , i really hope i can get this fixed

What is the resolution you want set at on that monitor for 144 Hz?

I’m not that familiar with kscreen but maybe try.

kscreen-doctor output.DP-2.mode.1

Just F.Y.I you are currently running on the amdgpu using eDP-1
Are you wanting to do 144Hz on that display because the ouput shows it can’t. You need to switch to nvidia output in order to that on display port using the nvidia graphics on the external monitor. :thinking:


No effect :frowning:

How should i switch to the nvidia output on the external monitor? I want to do 144hz on the external display

Have you tried running on xorg?

Yeah that’s what came by default, xorg would horribly stutter on my second monitor and only the cursor seemed to be running at 144hz, that’s why i switched to wayland

Okay …so when it running on xorg does it actually show it’s using the nvidia graphics?

i logged into a x11 plasma session and did inxi -G

  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nvidia
    v: 515.48.07
  Device-2: AMD Renoir driver: amdgpu v: kernel
  Device-3: Luxvisions Innotech HP Wide Vision HD Camera type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 driver: X:
    loaded: amdgpu,nvidia unloaded: modesetting
    gpu: amdgpu,nvidia,nvidia-nvswitch resolution: 1: 1920x1080
    2: 1920x1080~60Hz
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.42 5.15.50-1-lts)
    v: 4.6 Mesa 22.1.2

So one has to figure out how to switch to nvidia on the external monitor. I would try using optimus-manager even if you have to try it on xorg first. Supposedly it works on Wayland too.


while switching to nvidia with optimus on xorg does seem to work fine, on wayland it remains the same. Honestly i dont know what else to try to make it work on my specific case on wayland and its such a shame because otherwise everything else went fine (ex: manjaro didnt even recognize the second screen to begin with)

I guess ill live with it on xorg for now and if anyone has any clue as to how to fix it be free to help, aditiionally, any clues as to how do i get audio over dp working? the nvidia-settings panel says audio over displayport is avaliable but it doesnt seem to work, all i can see on the kde settings panel is “HDA Nvidia” showing up under the “Inactive Cards” section (audio did work under windows) Thanks in advance :smiley_cat: