100% Transparency in Terminal EOS 8/17/19

Default configuration on a fresh install suffers from completely transparent terminal.

If you right click in the body of the terminal, select preferences, click on the Appearance tab…can you change the transparency then?

I did!

Still, users may face difficulty reading white text on a transparent background with 0% opacity.

Default configuration should be appealing, easy on the eyes. :slightly_smiling_face:

1 Like

Yeah, If a choice in default settings between too much transparency or solid color, go solid. It is better if new users have to post here and ask “how do I make the terminal transparent” than the other way around.

2 Likes

This is very different from my personal experience. I didn’t have this issue with the 7/15/19 release. Is this from the 8/17/19 release? If so, this will kind of beg the question:

Is this an EndeavourOS default setting, or is this something that’s happened because of the new Xfce update? Or, could it be Cosmic Rays? (FYI: I attribute a lot of unexplained to Cosmic Rays)

I do agree with @Beardedgeek72 that a default should be set to opaque as apposed to transparent. Let the user decide after that. Making it difficult out of the box isn’t the best way to make friends and influence others.

Then again, could this be an aberration that isn’t even EOS? I haven’t seen this in any other post so far since the last installer was released. It would be interesting to know why this is happening.

1 Like

Yes.

Not an XFCE default.

A new EOS default is to blame, as you can see here (git).

1 Like

Yup. I see that. Thank you.

IMO, that’s an improper setting. I know I’m not part of the team, but it should be changed to be opaque.

Thanks, @Computer, for showing me.

2 Likes

Thank you for pointing that one out, after the xfce update there were other issues to solve, so this one got overlooked.

6 Likes

Oh, no rush! Wanted to report it so it’d get addressed in the future. :slightly_smiling_face::+1:

4 Likes
BackgroundDarkness=0.800000
MiscSearchDialogOpacity=100
MiscShowUnsafePasteDialog=TRUE
BackgroundMode=TERMINAL_BACKGROUND_TRANSPARENT
BackgroundDarkness=0,800000
MiscSearchDialogOpacity=100	
MiscShowUnsafePasteDialog=TRUE	
BackgroundMode=TERMINAL_BACKGROUND_TRANSPARENT

do you see the difference?

There is this change comma and point i do not know why it is changing all the time… may on pushing it to github or something related to editor used…

Didn’t it have to do with the Xfce 4.14 update?

I do not know how this happen, I do change it back very often and it do change on its own in the process…

I identify now where it changes from point to comma…

on git clone to local, after cloning the point is changed to comma… (very strange)
may related to locale settings at my build system? i do build insid ea chroot, but cloning i do manually as i need to change some files before building… i will check if it will be happen also if i git clone on system with en locale…

I tried git clone with different locales but it didn’t change the dot to comma.
So must be something else, maybe copying or setting up config somewhere later, after “git clone”?

BackgroundDarkness could be changed to plain 1
No decimals, dots or anything but 1

hm… may on pushing it then? as i am sure i check it 3 times before i do upload my changes…

good trick :wink:

1 Like

Nice discovery!

You can use run_before_mksquash to edit the file if you can’t find another solution. A simple sed can do the job.

till i do not know what the heck can change a point to a comma i am not happy with it…

Let me check if that happens here too…

Edit: i have the same that github.

@joekamprad should it be comma or dot?