100% crash upon loading into Team Fortress 2

Intel i5 1240P

First, I installed Vulkan, mesa and lib32-mesa.

Then I tried to play Team Fortress 2. It always crashes within ten seconds of loading into the game. Prior to the crash, things run smoothly.

I have tried:

  • Change powerprofilectl profile to “Power”

  • Force usage of Steam Linux Runtime. I believe I am running the native Linux version of the game.

  • Downgrade libx11 to 1.8.3

  • This

  • Changing game to windowed mode

  • The “Fixing bugs with newer SDL2” section of this (I’m not using mastercomfig)

  • Setting launch options, as recommended by some on ProtonDB: -novid -nojoy -nosteamcontroller -nohltv -particles 1 -precachefontchars -noquicktime -fps_max 60

  • Install gamemode and adding gamemoderun %command% to the aforementioned launch options

  • Restarting throughout.

Nothing has worked so far. I’m surprised this is so difficult, because TF2 is supposed to be a posterchild of clean Linux gaming. I’m new to Endeavour OS, and I’m treating it as an intro to Arch, but I don’t think I messed up the driver setup, because at least some other 3d games do run. Running Steam from the command line, then launching TF2, yields a bunch of text which I do not understand at all, but which I’m hoping an expert may be able to glean for a diagnosis. Here it is.

can you report

inxi -Fza


  Kernel: 6.2.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: initrd=\857dd328bebd488ca13893eaf349a5b2\6.2.1-arch1-1\initrd
    nvme_load=YES rw root=UUID=e6ecc388-b53c-4107-9669-6d2e73f4060f
  Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm:
    1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: EndeavourOS
    base: Arch Linux
  Type: Laptop System: Framework product: Laptop (12th Gen Intel Core) v: A4
    serial: <superuser required>
  Mobo: Framework model: FRANMACP04 v: A4 serial: <superuser required>
    UEFI: INSYDE v: 03.05 date: 08/23/2022
  ID-1: BAT1 charge: 50.1 Wh (92.3%) condition: 54.3/55.0 Wh (98.8%)
    volts: 16.7 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
    status: discharging cycles: 10
  Info: model: 12th Gen Intel Core i5-1240P bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x429
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
    L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2109 high: 3496 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3496 2: 2100 3: 3195
    4: 2100 5: 551 6: 2100 7: 1328 8: 2100 9: 2100 10: 2100 11: 2815 12: 1369
    13: 2100 14: 2100 15: 2100 16: 2100 bogomips: 67600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:4626
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2256x1504 s-dpi: 96 s-size: 596x397mm (23.46x15.63")
    s-diag: 716mm (28.19")
  Monitor-1: eDP-1 model: BOE Display 0x095f built: 2019 res: 2256x1504
    hz: 60 dpi: 201 gamma: 1.2 size: 285x190mm (11.22x7.48") diag: 343mm (13.5")
    ratio: 3:2 modes: 2256x1504
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0403
  Sound API: ALSA v: k6.2.1-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: a6:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:3 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 96.44 GiB (10.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU010TZ
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 002C temp: 35.9 C scheme: GPT
  ID-1: / raw-size: 570.34 GiB size: 560.32 GiB (98.24%)
    used: 96.26 GiB (17.2%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  Alert: No swap data was found.
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 317 Uptime: 11m wakeups: 21920 Memory: 15.34 GiB
  used: 3.99 GiB (26.0%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1149
  libs: 333 tools: yay Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25

That’s a really good command to know.

1 Like

Hello, I recently installed ‘Team Fortress 2’ on my PC. But friends, I am having a serious problem, after a few minutes of gameplay, the black screen appears. But I can listen to the game audio. Could someone please tell me why this happens? I am utterly confused about getting the issue. Please help.

I would open a new thread and describe the issue in more detail. Also include the output of the above mentioned inxi -Fza command

After posting the thread here, I searched online and came across this useful guide. It helps me a lot to solve the issue.

That’s such generic, bullshit copy paste article.

You are posting on Linux forum about your issue, and then following Windows specific crappy article to fix your issue?

It’s such a non-sequitur that I wouldn’t get mad about it. cornellwaelchi may be a bot of some kind of bot…