Zstd extraction error during Installation in Virtualbox

Hi, first time poster, I’ve never used Endeavour before and was hoping to try it out with a VM before any kind of metal installation. I keep running into errors during pacstrap, the first were keyring-based and I managed to fix these with sudo pacman-key --refresh-keys (however this was already strange as, at the very top of the Artemis ISO page, it seems to say this shouldn’t be an issue anymore), however there’s another error, here is the relevant section of the log:

2022-07-14 - 17:34:44 [6]: [PYTHON JOB]: "pacstrap: installing libbpf..." 
2022-07-14 - 17:34:44 [6]: [PYTHON JOB]: "pacstrap: installing iproute2..." 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: error: could not extract /tmp/calamares-root-4vu1jl8u/usr/share/tc/normal.dist (Zstd decompression failed: Restored data doesn't match checksum)" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: error: problem occurred while installing iproute2" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: Optional dependencies for iproute2" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: db: userspace arp daemon [pending]" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: libcap: tipc [installed]" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: linux-atm: ATM support" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: error: could not commit transaction" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: error: failed to commit transaction (transaction aborted)" 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: Errors occurred, no packages were upgraded." 
2022-07-14 - 17:34:45 [6]: [PYTHON JOB]: "pacstrap: ==> ERROR: Failed to install packages to new root" 
2022-07-14 - 17:34:45 [6]: virtual void Calamares::JobThread::run()
    Skipping non-emergency job "Generate machine-id." 
2022-07-14 - 17:34:45 [6]:     ..  Skipping non-emergency job "fstab"

As far as I can tell, the file it references is always different, I thought maybe it was fs-based so tried both fixed size and dynamically allocated .vdis, and with and without swap, all without any progress.
Any help is appreciated, thanks in advance.

Hey!

I suspect it’s some very serious VirtualBox bug, so for now it’s unusable for me as well, take a look here

P.S. Btw although initially i’ve said only Windoze - it’s also happens for Linux guests,for example if i start to update existing VM it will first blink with some colors (which kinda tells that it might be video related), but then it’s doing all kinds of integrity check failures etc, terminal crashes, then vm might crash…It’s a disaster.

What’s your GPU btw, Nvidia?

Ah I see, thanks for the link.
I run an AMD GPU, to be honest I haven’t noticed any video issues as of yet. Other software that I try to load in the live environment also crashes unexpectedly, only seconds after I start it. Unlike you though, the machine itself stays up indefinitely.

Updating to v6.1.36 seems to fix this.

1 Like

Indeed, they finally fixed this mess :upside_down_face:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.