Youtube using a lot of cpu

This does not tell you which decoder is used, play a youtube video and press ctrl+shift+i , and look for “media”.

Since some time I had to disable (#)
on amd and intel igpu to get “vaapi true” in chromium (probably the same in brave).

…my flags:

Graphics Feature Status
Canvas: Hardware accelerated
Canvas out-of-process rasterization: Enabled
Direct Rendering Display Compositor: Disabled
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
OpenGL: Enabled
Rasterization: Hardware accelerated on all pages
Raw Draw: Enabled
Video Decode: Hardware accelerated
Video Encode: Hardware accelerated
Vulkan: Enabled
WebGL: Hardware accelerated
WebGL2: Hardware accelerated
WebGPU: Disabled


Also a very convenient method is play-with-mpv .

1 Like

I will surely check this out…thank you

What about Firefox? Same problem?

1 Like

i dont use firefox

This is the status

Can you tell how did you enavle these flags…what is the optimum cpu usage while playing videos at 720p…like mine is about 50 percent

…to help you, you have to help us

show output of

inxi -Fazy

your flags


your Brave launch command

brave --HereAreMyFlags


Kernel: 6.2.2-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-linux
root=UUID=56172e9c-61a1-4a1b-b02c-980ec2625676 rw quiet splash loglevel=3
udev.log_level=3 vt.global_cursor_default=0
Desktop: i3 v: 4.22 info: polybar vt: 1 dm: SDDM Distro: Archcraft
base: Arch Linux
Type: Laptop System: Acer product: Aspire A315-22 v: V1.09
serial: Chassis: type: 10 serial:
Mobo: SR model: Rose_SR v: V1.09 serial: UEFI: Phoenix
v: 1.09 date: 05/15/2020
ID-1: BAT0 charge: 14.4 Wh (62.1%) condition: 23.2/25.1 Wh (92.4%)
volts: 11.1 min: 11.4 model: LGC AC14B18J type: Li-ion serial:
status: discharging cycles: 2
Info: model: AMD A4-9120e RADEON R3 4 COMPUTE CORES 2C+2G bits: 64 type: MCP
arch: Excavator level: v3 note: check built: 2015 process: GF 28nm
family: 0x15 (21) model-id: 0x70 (112) stepping: 0 microcode: 0x6006705
Topology: cpus: 1x cores: 2 smt: cache: L1: 192 KiB
desc: d-2x32 KiB; i-2x64 KiB L2: 2 MiB desc: 2x1024 KiB
Speed (MHz): avg: 1100 min/max: 1100/1500 boost: enabled scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 1100 2: 1100
bogomips: 5991
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT disabled
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics]
vendor: Acer Incorporated ALI driver: amdgpu v: kernel arch: GCN-3
code: Volcanic Islands process: TSMC 28nm built: 2014-19 ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 00:01.0 chip-ID: 1002:98e4
class-ID: 0300
Device-2: Quanta VGA WebCam type: USB driver: uvcvideo bus-ID: 2-4:3
chip-ID: 0408:a031 class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: Picom v: git-c4107 driver: X: loaded: amdgpu
unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x07cb built: 2018
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: OpenGL v: 4.5 Mesa 22.3.6 renderer: AMD Radeon Graphics (stoney LLVM
15.0.7 DRM 3.49 6.2.2-arch1-1) direct-render: Yes
Device-1: AMD vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus-ID: 00:01.1 chip-ID: 1002:15b3 class-ID: 0403
Device-2: AMD Family 15h Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a
class-ID: 0403
Sound API: ALSA v: k6.2.2-arch1-1 running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.66 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 01:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp1s0 state: down mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel modules: wl pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlan0 state: up mac:
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb
v: 0.8 bus-ID: 1-1.1:3 chip-ID: 04ca:3015 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 1.03 TiB used: 8.11 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte model: GP-GSM2NE3128GNTD
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: rev: EDFMB0.5 temp: 31.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: rev: ACM2 scheme: GPT
ID-1: / raw-size: 118.74 GiB size: 116.32 GiB (97.96%) used: 8.11 GiB (7.0%)
fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Alert: No swap data was found.
System Temperatures: cpu: 43.8 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Processes: 169 Uptime: 5m wakeups: 1 Memory: 7.17 GiB used: 1.19 GiB (16.6%)
Init: systemd v: 253 default: graphical tool: systemctl Compilers:
gcc: 12.2.1 Packages: pm: pacman pkgs: 1009 libs: 235 tools: yay Shell: Zsh
v: 5.9 running-in: alacritty inxi: 3.3.25

Please edit your post for better readability. ( </> …this is the magic sign).
What about the rest ?

1 Like

Gees, I wish I could edit that post.

I use Brave as well but I never had this kind of high CPU usage. And are you sure you’re using EndeavourOS?

We can be shure, he’s not (but I don’t care)

Desktop: i3 v: 4.22 info: polybar vt: 1 dm: SDDM Distro: Archcraft
Info: model: AMD A4-9120e RADEON R3 4 COMPUTE CORES 2C+2G bits: 64 type: MCP
Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics]
driver: amdgpu v: kernel arch: GCN-3
Memory: 7.17 GiB used: 1.19 GiB (16.6%)
Alert: No swap data was found.

…but at least we know, he is on AMD IGPU and hazardous running 8 GIB memory without swap.

Yes, I agree. Wouldn’t it be better if he had a swap or a ZRAM.

Yeah im using archcraft…and im on this forum as this is the most active forum in terms of arch linux…

I guess zram os for low memory system…and yeah my Cpu is kinda old…I had low budget while buying this laptop

This might be an active forum for an Arch-based distro but this is not what you’re using. 8Gb’s are considered SWAP-worthy nowadays.

And from your responses, it seems you want a premade solution without testing things. @banjo did ask for some other information as well which you didn’t provide.

Then @Zircon34 asked if the same thing happens when you use Firefox you just said

Without even trying. A lot of people, are turned off when you reply like this.

As far as I know, Archcraft does do a lot of customizing so there may be many things that are causing the problem. Even a plugin you have.

Did you try using the Brave private browsing mode to see at least that mode also has the same issue?

1 Like

yeah I installed firefox right now and its working fine…I installed h264ify now cpu usage is normal…

Yeah “Based” on Arch. Might differ. That’s why it’s always better to ask in those forums. Not in other forums. Because we don’t know what’s under the hood.

No sir till now archcraft doesnt have the kind of support which eos gives…that is why im still on this forum :slight_smile:

No problem. We all are one family. It’s best to mention your distro first. It’ll help immensely. Because all here thinks you’re on :enos:. I don’t know if this needs to be moved to other distros though. I leave it up to our moderators @ricklinux and @dalto.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.