Yesterday the update breaks my system

Yesterday the update brakes my system, even Timeshift does not help and rolling back ends with an error. When i boot the system there ist an error: Failed Tod mount /boot/efi . What i have got to do?

But this grub problem was 19 days before. How can i see my grub version, i just can boot into command line?

All the latest grub-packages have that same error, still. (Latest GRUB package here.)

Which version?
pacman -Qss grub

You need to run grub-install so it is best to follow the instructions given above.

1 Like

You could boot up your live ISO and chroot into your system.

Perform the update in chroot.
Also check the UUID of your EFI system partition and make sure it matches the one in /etc/fstab.

Here is how to chroot for UEFI systems:

If something is still broken, perhaps it might be possible to troubleshoot further without rolling back a timeshift snapshot.

I have grub version 2:2.06.r322.gd9b4638c5-4 . Grub Install gives me the following message: Efi directory can not be found.

Show us output of:

lsblk -f

thank you. timeshift does not wirk, i have tryed it already as mentioned. i will chroot into the system, i have never done this before, perhaps i will learn something for later.

In the live session, make sure you connect to internet.
If anything is unclear, don’t hesitate to post on the forum. You could do that from the live session.

What does the ss in pacman -Qss grub stand for? I only know this as pacman -Qss [package_name]. What is the difference?

Maybe you are onto something, and I was wrong…

To search for already installed packages:

$ pacman -Qs string1 string2

I’ve done it this way before, it is why I memorized it - perhaps wrongly with the same result? Maybe pacman just “swallows” the second “s”?

This doesn’t appear related to the recent grub issues.

It looks like your EFI partition is failing to mount.

Can you share the output of

lsblk -f
cat /etc/fstab

I just saw it:

[uwe@HAL ~]$ pacman -Qs grub
local/grub 2:2.06.r322.gd9b4638c5-4
GNU GRand Unified Bootloader (2)
[uwe@HAL ~]$ pacman -Q grub
grub 2:2.06.r322.gd9b4638c5-4

pacman -Qs grub additionally prints the complete name of the program.

However, I do not see any difference in the output if
$ $ pacman -Qss grub or $ pacman -Qs grub

If you have not chrooted yet, you may not need to.

What terminal did you use to get this? I suppose TTY.
If you were on TTY, you can keep on troubleshooting from there and get info as requested.

This is not a terminal error. You have booted to your kernel, which is probably on your root FS.
Get fstab info and lsblk -f .
It seems you may have internet, so use EnOS sendlog command (as advised in EnOS wiki).

See the picture

After the boot fails, it should offer maintenance mode

From there, what does systemctl status boot-efi.mount show?

The UUID looks correct, I wonder if there is something wrong with that partition.

EDIT: Actually, I wonder if the kernel module for vfat is missing.

1 Like

Could that even be possible? :scream:
What edge case got into your mind? :laughing:

@doko1975 can you give more info about what changes you might have done in your system and/or partitions before this happens?
Did you update system packages with failure? Check pacman log, if you can’t remember.
Can you run package updates now?
Error messages are important.

It seems more like a file system or drive failure. I hope I’m wrong…

It happens when the kernel version and kernel modules version get out of alignment so the kernel can’t load any of the modules.

1 Like

I can’t run system package updates.
systemctl status boot-efi.mount is

That looks to me like your kernel modules are mismatched or missing.

I would boot off the live ISO, arch-chroot into your system and reinstall your kernel.