Yay update stops on celt package

trying to update yay I get the following:

(0/1) Downloaded PKGBUILD: celt
→ error fetching celt: error: The following untracked working tree files would be overwritten by merge:
010-celt-fix-tandem-test.patch
Please move or remove them before you merge.
Aborting
context: exit status 1

Press ENTER to close this window:

This is git telling you that it can’t merge without overwriting the changes you’ve made. Did you change the PKGBUILD file previously? If you did, you simply have to reset the changes (inside the cloned git repo containing the PKGBUILD file) and run the update again.

When it asks about clean building answer a

Does yay re-clone the repo when it does clean building?

Yes. It deletes all the working files.

1 Like

Thanks for the confirmation.

1 Like

Thanks, but never dared to change anything

Thanks, I have seen this advise, serching the internet for a solution, but it only asks if I do not want to update the package. But I do want to update the package.

No mention of clean building. Do I need a special command for that?

Perhaps you disabled it in the settings?

Try this:

yay --cleanmenu -Syu

certainly not

Tried it, but the reply is almost the same:

:: (0/1) Downloaded PKGBUILD: celt
 -> error fetching celt: error: The following untracked working tree files would be overwritten by merge:
	010-celt-fix-tandem-test.patch
Please move or remove them before you merge.
Aborting 
	 context: exit status 1

Is it wrong to simply delete the following damned file?

010-celt-fix-tandem-test.patch

But I do not know where it is

Can you share the full output from the command:

yay --cleanmenu -Syu

Certainly and thanks for your commitment:

[f@tablet ~]$ yay --cleanmenu -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Searching AUR for updates...
:: Searching databases for updates...
 -> Packages not in AUR: chrome-gnome-shell  gfbgraph  gnome-books  gnome-documents  gnome-getting-started-docs  gnome-online-miners  gnome-software-packagekit-plugin  grub-tools  grub2-theme-endeavouros  ipw2100-fw  ipw2200-fw  js60  js68  js78  libgweather  libopenaptx  libsidplay  libzapojit  tracker  tracker-miners  vino  webkit2gtk-5.0
 -> Flagged Out Of Date AUR Packages: snapd
 -> gdome2: local (0.8.1-7) is newer than AUR (0.8.1-1)
 -> gmetadom: local (0.2.6-10) is newer than AUR (0.2.6-1)
 -> paper-icon-theme: local (1.5.0.832.aa3e8af-1) is newer than AUR (1.5.0-3)
:: 1 dependency will also be installed for this operation.
   aur/gklib   -> 5.1.1-4

:: 13 packages to upgrade/install.
13  core/file                      5.44-3      -> 5.45-1
12  core/libnftnl                  1.2.5-1     -> 1.2.6-1
11  extra/alsa-card-profiles       1:0.3.77-1  -> 1:0.3.77-2
10  extra/gst-plugin-pipewire      1:0.3.77-1  -> 1:0.3.77-2
 9  extra/libpipewire              1:0.3.77-1  -> 1:0.3.77-2
 8  extra/nftables                 1:1.0.7-2   -> 1:1.0.8-2
 7  extra/pipewire                 1:0.3.77-1  -> 1:0.3.77-2
 6  extra/webrtc-audio-processing  0.3.1-3     -> 0.3.1-4
 5  aur/celt                       0.11.3-5    -> 0.11.3-6
 4  aur/metis                      5.1.0.p11-1 -> 5.2.1-2
 3  aur/openssl-1.0                1.0.2.u-5   -> 1.0.2.u-6
 2  aur/snapd                      2.58.3-1    -> 2.60-1
 1  aur/zoom                       5.13.10-1   -> 5.15.5-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
==> 
AUR Explicit (2): snapd-2.60-1, zoom-5.15.5-1
AUR Dependency (4): metis-5.2.1-2, openssl-1.0-1.0.2.u-6, celt-0.11.3-6, gklib-5.1.1-4
Sync Dependency (8): gst-plugin-pipewire-1:0.3.77-2, webrtc-audio-processing-0.3.1-4, file-5.45-1, pipewire-1:0.3.77-2, libpipewire-1:0.3.77-2, nftables-1:1.0.8-2, alsa-card-profiles-1:0.3.77-2, libnftnl-1.2.6-1
:: PKGBUILD up to date, skipping download: zoom
:: PKGBUILD up to date, skipping download: openssl-1.0
:: PKGBUILD up to date, skipping download: snapd
:: PKGBUILD up to date, skipping download: metis
:: PKGBUILD up to date, skipping download: gklib
:: (0/1) Downloaded PKGBUILD: celt
 -> error fetching celt: error: The following untracked working tree files would be overwritten by merge:
	010-celt-fix-tandem-test.patch
Please move or remove them before you merge.
Aborting 
	 context: exit status 1

[f@tablet ~]$ 

7  extra/pipewire                 1:0.3.77-1  -> 1:0.3.77-2
 6  extra/webrtc-audio-processing  0.3.1-3     -> 0.3.1-4
 5  aur/celt                       0.11.3-5    -> 0.11.3-6
 4  aur/metis                      5.1.0.p11-1 -> 5.2.1-2
 3  aur/openssl-1.0                1.0.2.u-5   -> 1.0.2.u-6
 2  aur/snapd                      2.58.3-1    -> 2.60-1
 1  aur/zoom                       5.13.10-1   -> 5.15.5-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
==> 
AUR Explicit (2): snapd-2.60-1, zoom-5.15.5-1
AUR Dependency (4): metis-5.2.1-2, openssl-1.0-1.0.2.u-6, celt-0.11.3-6, gklib-5.1.1-4
Sync Dependency (8): gst-plugin-pipewire-1:0.3.77-2, webrtc-audio-processing-0.3.1-4, file-5.45-1, pipewire-1:0.3.77-2, libpipewire-1:0.3.77-2, nftables-1:1.0.8-2, alsa-card-profiles-1:0.3.77-2, libnftnl-1.2.6-1
:: PKGBUILD up to date, skipping download: zoom
:: PKGBUILD up to date, skipping download: openssl-1.0
:: PKGBUILD up to date, skipping download: snapd
:: PKGBUILD up to date, skipping download: metis
:: PKGBUILD up to date, skipping download: gklib
:: (0/1) Downloaded PKGBUILD: celt
 -> error fetching celt: error: The following untracked working tree files would be overwritten by merge:
	010-celt-fix-tandem-test.patch
Please move or remove them before you merge.
Aborting 
	 context: exit status 1

[f@tablet ~]$ 

Try rm -rf ~/.cache/yay/celt and then yay

this time it allowed me to reinstall celt and it finished update without errors. So deleting that cache did the trick.

Many thanks @dalto without your help I would never had found it . I had already tried everything

1 Like

Glad to help!

As an FYI, the reason the clean build wasn’t working for you is that it was failing before it had a chance to ask you the question.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.