Yay showing ���� where text belongs to be

Greetings! Here some info:
Im using XFCE4


Tried changing font and it don’t fix issue.

Edit:

Have a nice day!

Probably you need to install some nerd-fonts for optimal presentation. I myself dont use xfce but under Appearenceyou can set the font.

https://docs.xfce.org/apps/xfce4-terminal/preferences

Happened me once when I had both nerd and awesome fonts installed. Removing other fixes it.

1 Like

I figured it out when and how it happened. It seems something (me or KDE system settings) completely create mess with my locales. Even bash giving an error:
bash: warning: setlocale: LC_CTYPE: cannot change locale (ru)
I’ve tried to make xfce using ru language and broke something :frowning:
About KDE settings: I was using plasme DE for a while and then I decided change it to xfce. I used KDE system setting to change language and something completely go wrong

have read here … " https://wiki.archlinux.org/title/Locale#Generating_locales "

2 Likes

Figured it out.
I had a config file in my home directory

~/.config/locale.conf

And it content some mess and was overriding system locales! So i just deleted it and run

unset LANG
source /etc/profile.d/locale.sh

For everyone who will have same error follow this advice :sweat_smile:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.