'yay -F' and 'yay -Ss' use different databases

I was trying to remember which package contained paccache, so I ran yay -F paccache and got this:

$ yay -F paccache
community/pacman-contrib 1.4.0-4 [installed: 1.5.0-1]

Confused at the version difference, I ran yay -Ss pacman-contrib and got this:

$ yay -Ss pacman-contrib
community/pacman-contrib 1.5.0-1 (38.5 KiB 107.5 KiB) (Installed)
    Contributed scripts and tools for pacman systems

When I first ran yay -F, it complained about the database not being up-to-date and suggested running yay -Fy. Running this same command, the database updated and now yay -F shows the updated info.

The question is: why is there a need to update the pacman database with (2) separate commands to get the right package info?

1 Like

They are two different databases that contain different information. Most people only use the package database so there is no need to update the files database everytime.


Interesting…OK, thanks for the info. I guess it wouldn’t hurt to update the files database at the same time as the package database (updating about 2x/week at the moment).

Try pacman -Fy and the do the test again.

Erm…he did: :wink:

Read too hastily, sorry about that.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.