Yay errors out

Posting here cause there doesn’t seem to be a general category for just general update issues.

I just used topgrade and was told there were 13 updates as well as a long list of warnings about various plasma 5.19.90 components being newer that their 5.19.5-1 counterparts. it kept failing to retrieve the various updates(ones I believe were installed yesterday) so I closed Konsole, updated the mirrors list with reflector, launched pamac and refreshed the databases. After refreshing Pamac informed me that my system is up to date. Thought that was a bit odd so I opened Konsole and ran yay and I got the below. Does any one have an idea what is goig on here? Thanks

[alienprober@TheMotrhership ~]$ yay
[sudo] password for alienprober: 
:: Synchronizing package databases...
error: failed retrieving file 'kde-unstable.db' from arch.hu.fo : 
error: failed retrieving file 'kde-unstable.db' from archmirror1.octyl.net : 
error: failed retrieving file 'kde-unstable.db' from arch.mirror.constant.com : 
error: failed retrieving file 'kde-unstable.db' from arlm.tyzoid.com : 
error: failed retrieving file 'kde-unstable.db' from ftp.sudhip.com : 
error: failed retrieving file 'kde-unstable.db' from mirror.lty.me : 
error: failed retrieving file 'kde-unstable.db' from mirrors.lug.mtu.edu : 
error: failed retrieving file 'kde-unstable.db' from reflector.luehm.com : 
error: failed to update kde-unstable (download library error)
error: failed retrieving file 'core.db' from arch.hu.fo : 
error: failed retrieving file 'core.db' from archmirror1.octyl.net : 
error: failed retrieving file 'core.db' from arch.mirror.constant.com : 
error: failed retrieving file 'core.db' from arlm.tyzoid.com : 
error: failed retrieving file 'core.db' from ftp.sudhip.com : 
error: failed retrieving file 'core.db' from mirror.lty.me : 
error: failed retrieving file 'core.db' from mirrors.lug.mtu.edu : 
error: failed retrieving file 'core.db' from reflector.luehm.com : 
error: failed to update core (download library error)
error: failed retrieving file 'extra.db' from arch.hu.fo : 
error: failed retrieving file 'extra.db' from archmirror1.octyl.net : 
error: failed retrieving file 'extra.db' from arch.mirror.constant.com : 
error: failed retrieving file 'extra.db' from arlm.tyzoid.com : 
error: failed retrieving file 'extra.db' from ftp.sudhip.com : 
error: failed retrieving file 'extra.db' from mirror.lty.me : 
error: failed retrieving file 'extra.db' from mirrors.lug.mtu.edu : 
error: failed retrieving file 'extra.db' from reflector.luehm.com : 
error: failed to update extra (download library error)
error: failed retrieving file 'community.db' from arch.hu.fo : 
error: failed retrieving file 'community.db' from archmirror1.octyl.net : 
error: failed retrieving file 'community.db' from arch.mirror.constant.com : 
error: failed retrieving file 'community.db' from arlm.tyzoid.com : 
error: failed retrieving file 'community.db' from ftp.sudhip.com : 
error: failed retrieving file 'community.db' from mirror.lty.me : 
error: failed retrieving file 'community.db' from mirrors.lug.mtu.edu : 
error: failed retrieving file 'community.db' from reflector.luehm.com : 
error: failed to update community (download library error)
error: failed retrieving file 'multilib.db' from arch.hu.fo : 
error: failed retrieving file 'multilib.db' from archmirror1.octyl.net : 
error: failed retrieving file 'multilib.db' from arch.mirror.constant.com : 
error: failed retrieving file 'multilib.db' from arlm.tyzoid.com : 
error: failed retrieving file 'multilib.db' from ftp.sudhip.com : 
error: failed retrieving file 'multilib.db' from mirror.lty.me : 
error: failed retrieving file 'multilib.db' from mirrors.lug.mtu.edu : 
error: failed retrieving file 'multilib.db' from reflector.luehm.com : 
error: failed to update multilib (download library error)
 endeavouros is up to date
 herecura is up to date
 chaotic-aur is up to date
error: failed to synchronize all databases
error installing repo packages
[alienprober@TheMotrhership ~]$

That looks like a network/dns issue.

It is failing to download the files from every mirror on your list.

It’s odd cause I don’t get why when I did topgrade it would tell me about the plasma files since I’m on the testing channel for plasma and I believe the 5.19.5-1 would be from the stable channel, and I’m sure the 13 updates it listed were the ones I installed yesterday. I remember the ones for audio cause after they were installed my sound stopped dropping down to 40% after boot, so they fixed that issue. I’ll try a reboot and try again. I’ll let you know what I get.

2 Likes

OK rebooted and ran yay again and got the same.

> [alienprober@TheMotrhership ~]$ yay
> [sudo] password for alienprober:
> :: Synchronizing package databases...
> error: failed retrieving file 'kde-unstable.db' from arch.hu.fo :  
> error: failed retrieving file 'kde-unstable.db' from archmirror1.octyl.net
> :
> error: failed retrieving file 'kde-unstable.db' from arch.mirror.constant.c
> om :
> error: failed retrieving file 'kde-unstable.db' from arlm.tyzoid.com :  
> error: failed retrieving file 'kde-unstable.db' from ftp.sudhip.com :  
> error: failed retrieving file 'kde-unstable.db' from mirror.lty.me :  
> error: failed retrieving file 'kde-unstable.db' from mirrors.lug.mtu.edu :  
> error: failed retrieving file 'kde-unstable.db' from reflector.luehm.com :  
> error: failed to update kde-unstable (download library error)
> error: failed retrieving file 'core.db' from arch.hu.fo :  
> error: failed retrieving file 'core.db' from archmirror1.octyl.net :  
> error: failed retrieving file 'core.db' from arch.mirror.constant.com :  
> error: failed retrieving file 'core.db' from arlm.tyzoid.com :  
> error: failed retrieving file 'core.db' from ftp.sudhip.com :  
> error: failed retrieving file 'core.db' from mirror.lty.me :  
> error: failed retrieving file 'core.db' from mirrors.lug.mtu.edu :  
> error: failed retrieving file 'core.db' from reflector.luehm.com :  
> error: failed to update core (download library error)
> error: failed retrieving file 'extra.db' from arch.hu.fo :  
> error: failed retrieving file 'extra.db' from archmirror1.octyl.net :  
> error: failed retrieving file 'extra.db' from arch.mirror.constant.com :  
> error: failed retrieving file 'extra.db' from arlm.tyzoid.com :  
> error: failed retrieving file 'extra.db' from ftp.sudhip.com :  
> error: failed retrieving file 'extra.db' from mirror.lty.me :  
> error: failed retrieving file 'extra.db' from mirrors.lug.mtu.edu :  
> error: failed retrieving file 'extra.db' from reflector.luehm.com :  
> error: failed to update extra (download library error)
> error: failed retrieving file 'community.db' from arch.hu.fo :  
> error: failed retrieving file 'community.db' from archmirror1.octyl.net :  
> error: failed retrieving file 'community.db' from arch.mirror.constant.com
> :
> error: failed retrieving file 'community.db' from arlm.tyzoid.com :  
> error: failed retrieving file 'community.db' from ftp.sudhip.com :  
> error: failed retrieving file 'community.db' from mirror.lty.me :  
> error: failed retrieving file 'community.db' from mirrors.lug.mtu.edu :  
> error: failed retrieving file 'community.db' from reflector.luehm.com :  
> error: failed to update community (download library error)
> error: failed retrieving file 'multilib.db' from arch.hu.fo :  
> error: failed retrieving file 'multilib.db' from archmirror1.octyl.net :  
> error: failed retrieving file 'multilib.db' from arch.mirror.constant.com :
> 
> error: failed retrieving file 'multilib.db' from arlm.tyzoid.com :  
> error: failed retrieving file 'multilib.db' from ftp.sudhip.com :  
> error: failed retrieving file 'multilib.db' from mirror.lty.me :  
> error: failed retrieving file 'multilib.db' from mirrors.lug.mtu.edu :  
> error: failed retrieving file 'multilib.db' from reflector.luehm.com :  
> error: failed to update multilib (download library error)
> endeavouros is up to date
> herecura is up to date
> chaotic-aur          1416.4 KiB  1168 KiB/s 00:01 [-----------------] 100%
> error: failed to synchronize all databases
> error installing repo packages
> [alienprober@TheMotrhership ~]$

EDIT:

Should add that the Pamac GUI still tells me the system is up to date.

You can’t download from any of the Arch mirrors but you can download from chaotic-aur. That is interesting.

Looks like heracura and endeavouros also work.

2 Likes

only archmirrors are failing:

so may faulty mirrorlist, create a new one with reflector-simple will help

4 Likes

OK so maybe something with them then? What about the plasma errors, any thoughts?

That is failing at the mirrors as well.

1 Like

That is probably caused by failing to download the kde-unstable database.

Here’s this if you guys think it might be of any help.

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

#IgnorePkg   =
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
ILoveCandy
#TotalDownload
# We cannot check disk space from within a chroot environment
#CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

[kde-unstable]
Include = /etc/pacman.d/mirrorlist

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

[endeavouros]
SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

[herecura]
Server = https://repo.herecura.be/$repo/$arch

[chaotic-aur]
SigLevel = Never
Server = http://lonewolf-builder.duckdns.org/$repo/x86_64
Server = http://chaotic.bangl.de/$repo/x86_64
Server = https://repo.kitsuna.net/x86_64

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Then it might be unrelated to the rest, cause I can see them having their server down getting ready for the official release.

as all the involved failing repos are mapped in etc/pacman.d/mirrorlist, I’d go with @joekamprad solution and try with reflector again

2 Likes

OK I missed that, sorry @joekamprad. Just did reflector again, reboot first or just try yay again?

no reboot needed for this to work

1 Like

I’d move [kde-unstable] in between [multilib] and [endeavouros] repos in /etc/pacman.conf.
But probably that won’t solve the issue…

Is there a compelling reason to use kde-unstable?

Try

sudo mv /etc/pacman.d/mirrorlist /etc/pacman.d/mirrorlist.bak
reflector --score 20 -f 20 -a 2 | sudo tee /etc/pacman.d/mirrorlist

If that works, great, if it doesn’t, undo it with

sudo mv /etc/pacman.d/mirrorlist.bak /etc/pacman.d/mirrorlist

and try something else.

In any case, run

sudo pacman -Syyu

to properly refresh your local package database.

1 Like

[quote=“joekamprad, post:15, topic:8901, full:true”]

[alienprober@TheMotrhership ~]$ yay
[sudo] password for alienprober: 
:: Synchronizing package databases...
 kde-unstable is up to date
 core is up to date
 extra                1639.6 KiB  10.5 MiB/s 00:00 [-----------------] 100%
 community               5.2 MiB  71.2 MiB/s 00:00 [-----------------] 100%
 multilib              157.1 KiB  0.00   B/s 00:00 [-----------------] 100%
 endeavouros is up to date
 herecura               69.2 KiB   212 KiB/s 00:00 [-----------------] 100%
 chaotic-aur          1417.1 KiB   996 KiB/s 00:01 [-----------------] 100%
:: Starting full system upgrade...
warning: bluedevil: local (1:5.19.90-1) is newer than extra (1:5.19.5-1)
warning: breeze: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: breeze-gtk: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: discover: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: drkonqi: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kactivitymanagerd: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kde-cli-tools: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kde-gtk-config: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kdecoration: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kdeplasma-addons: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kgamma5: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: khotkeys: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kinfocenter: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kmenuedit: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: knetattach: local (5.19.90-3) is newer than extra (5.19.5-1)
warning: kscreen: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kscreenlocker: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: ksshaskpass: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: ksysguard: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kwallet-pam: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kwayland-integration: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kwayland-server: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: kwin: local (5.19.90-2) is newer than extra (5.19.5-2)
warning: kwrited: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: libkscreen: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: libksysguard: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: milou: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: oxygen: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-browser-integration: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-desktop: local (5.19.90-3) is newer than extra (5.19.5-1)
warning: plasma-integration: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-nm: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-pa: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-sdk: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-thunderbolt: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-vault: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: plasma-workspace: local (5.19.90-1) is newer than extra (5.19.5-3)
warning: plasma-workspace-wallpapers: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: polkit-kde-agent: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: powerdevil: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: sddm-kcm: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: systemsettings: local (5.19.90-1) is newer than extra (5.19.5-1)
warning: xdg-desktop-portal-kde: local (5.19.90-1) is newer than extra (5.19.5-1)
resolving dependencies...
looking for conflicting packages...

Packages (2) freetype2-2.10.3-1  lib32-freetype2-2.10.3-1

Total Download Size:    0.85 MiB
Total Installed Size:   2.42 MiB
Net Upgrade Size:      -0.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 freetype2-2.10.3...   498.8 KiB  4.31 MiB/s 00:00 [-----------------] 100%
 lib32-freetype2-...   376.0 KiB  52.5 MiB/s 00:00 [-----------------] 100%
(2/2) checking keys in keyring                     [-----------------] 100%
(2/2) checking package integrity                   [-----------------] 100%
(2/2) loading package files                        [-----------------] 100%
(2/2) checking for file conflicts                  [-----------------] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
Using system disk as snapshot device for creating snapshots in BTRFS mode

/dev/nvme0n1p2 is mounted at: /run/timeshift/backup, options: rw,relatime,ssd,space_cache,autodefrag,subvolid=5,subvol=/

Creating new backup...(BTRFS)
Saving to device: /dev/nvme0n1p2, mounted at path: /run/timeshift/backup
Created directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-10-13_06-50-14
Created subvolume snapshot: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-10-13_06-50-14/@
Created control file: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-10-13_06-50-14/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2020-10-13_06-50-14': ondemand
------------------------------------------------------------------------------

/dev/nvme0n1p2 is mounted at: /run/timeshift/backup, options: rw,relatime,ssd,space_cache,autodefrag,subvolid=5,subvol=/

------------------------------------------------------------------------------
Removing snapshot: 2020-10-12_09-12-40
Deleting subvolume: @ (Id:383)
Deleted subvolume: @ (Id:383)

Destroying qgroup: 0/383
Destroyed qgroup: 0/383

Deleted directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2020-10-12_09-12-40
Removed snapshot: 2020-10-12_09-12-40
------------------------------------------------------------------------------
Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
Detecting snapshots ...
Info: Separate boot partition not detected 
Found snapshot: 2020-10-13 06:50:14 | timeshift-btrfs/snapshots/2020-10-13_06-50-14/@
Found snapshot: 2020-10-13 05:32:03 | timeshift-btrfs/snapshots/2020-10-13_05-32-03/@
Found snapshot: 2020-10-12 10:01:10 | timeshift-btrfs/snapshots/2020-10-12_10-01-10/@
Found snapshot: 2020-10-09 05:00:02 | timeshift-btrfs/snapshots/2020-10-09_05-00-02/@
Found snapshot: 2020-10-05 06:59:30 | timeshift-btrfs/snapshots/2020-10-05_06-59-30/@
Found snapshot: 2020-10-02 05:00:01 | timeshift-btrfs/snapshots/2020-10-02_05-00-01/@
Found snapshot: 2020-10-01 04:32:11 | timeshift-btrfs/snapshots/2020-10-01_04-32-11/@
Found 7 snapshot(s)
done
:: Processing package changes...
(1/2) upgrading freetype2                          [-----------------] 100%
(2/2) upgrading lib32-freetype2                    [-----------------] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
:: Searching databases for updates...
:: Searching AUR for updates...
 -> bluedevil: local (1:5.19.90-1) is newer than extra (1:5.19.5-1)
 -> breeze: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> breeze-gtk: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> discover: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> drkonqi: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kactivitymanagerd: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kde-cli-tools: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kde-gtk-config: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kdecoration: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kdeplasma-addons: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kgamma5: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> khotkeys: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kinfocenter: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kmenuedit: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> knetattach: local (5.19.90-3) is newer than extra (5.19.5-1)
 -> kscreen: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kscreenlocker: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> ksshaskpass: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> ksysguard: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kwallet-pam: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kwayland-integration: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kwayland-server: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> kwin: local (5.19.90-2) is newer than extra (5.19.5-2)
 -> kwrited: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> libkscreen: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> libksysguard: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> milou: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> oxygen: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-browser-integration: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-desktop: local (5.19.90-3) is newer than extra (5.19.5-1)
 -> plasma-integration: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-nm: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-pa: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-sdk: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-thunderbolt: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-vault: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> plasma-workspace: local (5.19.90-1) is newer than extra (5.19.5-3)
 -> plasma-workspace-wallpapers: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> polkit-kde-agent: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> powerdevil: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> sddm-kcm: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> systemsettings: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> xdg-desktop-portal-kde: local (5.19.90-1) is newer than extra (5.19.5-1)
 -> Orphaned AUR Packages:  lib32-gmp4
 -> Flagged Out Of Date AUR Packages:  snapd-git
 there is nothing to do
[alienprober@TheMotrhership ~]$

Every time you change the mirror list, run

sudo pacman -Syyu

to properly refresh your local package database.

1 Like

Do I still need to try what you posted?