Yay error? Unable to update AUR packages

Hi there,

I recently upgraded my system after approximately 2 months.

I was able to update packages installed by pacman perfectly fine after running sudo pacman -S archlinux-keyring, however when I try updating AUR packages with yay -Syu I get the below message:

unable to CreateHandle: could not find or read directory

What does this mean exactly? and any pointers on where to begin trouble shooting this issue?

I have already attempted to reinstall yay but the issue persists…

Can you share the full output from yay

Unfortunately no matter whatever yay command I run, the output I get is:

unable to CreateHandle: could not find or read directory

There is no output before or after that?

Nope nothing.

Even something as simple as yay —version I get the same output.

I know I am not supposed to run yay with sudo, but just to test running sudo yay —version gives me the desired output.

Could this be done sort of permissions issue?

what does: pacman -Qs pamac say you?
remove pamac … you can reinstalll after update was working…

Yes. What does ls -l ~/.cache return?

Do you have yay aliased to anything? Such that extra parameters might be getting in the way? type yay would show if so.

Try doing a pacman -Syu first, then reboot. Then try updating your AUR packages.

1 Like

Can you try paru instead of yay? Does that work?
Or maybe deleting ~/.cache/yay helps?

thank you all for the suggestions! it turns out yay was aliased to yay -aur for some reason as @andrewb mentioned, commented it out and everything seems to be working as intended.

1 Like

yay, you are back to normal and I’m glad it worked. (pun intended)

Often times it’s good to recall your aliases and shortcuts.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.